new server without disk quotas

Hi

I’ve just had a interworx server setup and it appears to not have quotas setup.
I’m getting a email from cron (every 5 minutes) stating:
repquota: Not all specified mountpoints are using quota.

My /etc/fstab has the 2 mounts specified as follows (which doesn’t have quota or usrquota options)

/dev/md1 / ext3 defaults 1 1
/dev/md0 /boot ext3 defaults 1 2

As I’ve never used quotas before on linux I’m not 100% sure how to proceed. A quick google turned up http://www.siliconvalleyccie.com/linux-adv/quota.htm which appears to be quite straight forward. Though the example was quotas on /home so it was possible without a reboot.

What would be the best way to turn on quota support for a new install?

Thanks in advance
Robert H

I’ve just had a interworx server setup and it appears to not have quotas setup.
I’m getting a email from cron (every 5 minutes) stating:
repquota: Not all specified mountpoints are using quota.

My /etc/fstab has the 2 mounts specified as follows (which doesn’t have quota or usrquota options)

/dev/md1 / ext3 defaults 1 1
/dev/md0 /boot ext3 defaults 1 2

As I’ve never used quotas before on linux I’m not 100% sure how to proceed. A quick google turned up http://www.siliconvalleyccie.com/linux-adv/quota.htm which appears to be quite straight forward. Though the example was quotas on /home so it was possible without a reboot.

What would be the best way to turn on quota support for a new install?

The current InterWorx-CP kickstart that Sago does apparently can’t handle the software RAID setups, the new installer will. To fix this problem just do the following:

change:


/dev/md1 / ext3 defaults 1 1

to:


/dev/md1 / ext3 defaults,usrquota,grpquota 1 1

then run:


mount -o remount /

Finally, run:


quotacheck -cvugmf -F vfsv0 /

to rebuild the initial quota files and you should be good robert.

Chris

Thanks very much for your prompt reply.
That works fine and all is well.