NodeWorx Slowness

Why does it take so long for each page in NodeWorx or SiteWorx to load? Whether it’s the simple summary front page, or a listing of every account on the box, it seems to take much longer than it should to load…

It’s not the server connection, as I’ve tried downloading a couple of very large photos I host on my personal site, and they load at the full speed of my broadband line - about 150 to 200 KB/second.

However, I’m not sure what it is that’s taking the time…:

I’ve noticed is that after clicking a link on the left menu, it sits for about 30 seconds to 1 minute, saying “Sending request to <server ip>”, and then suddenly loads the page within another couple of seconds. (This is in Opera 8.54 on WinXP Pro SP2)

Using Firefox it is the same - sits “Loading” for about the same amount of time, and then suddenly loads the page within another few seconds.

I’ve tried disabling the firewall running on the server, but it makes no difference. I’ve tried non-SSL mode too, again with no noticeable difference. Lastly, I also tried other IPs on the box, again: no difference.

The Interworx Demo was down when I tried it, so I was unable to compare loading times between that and my server.

I can’t think of anything that’s causing this slowness… The Load Average seems to make no difference (until it gets into high double-figures). CPU Usage is usually pretty low, as is RAM usage.

Anyone have any ideas?

This is indeed highly unusual Fr3d. Sometimes strange delays can be DNS related, if your server can’t do DNS lookups for some reason, or has some invalid DNS servers listed in it’s /etc/resolv.conf file. But I haven’t heard of InterWorx delays like this due to DNS issues, so that’s just a guess.

The demo should be up now, if you’d like to give it a whril to compare.


Well DNS lookups shouldn’t be an issue. HostnameLookups is set to Off by default in Apache and Interworx, and I’ve double checked it is set to off too.

Wow - the demo is a hell of a lot faster! Between two and five seconds to wait, and then the page loads :slight_smile:

My box has been experiencing some problems which I forgot to take into account earlier, which I could account for some of the slowness I’m experiencing. I’m just waiting for a good time to reboot (or for it to panic again) to load the new pathced kernel…

I’ll let you know if it’s any faster once its rebooted :slight_smile:

Well I’ve rebooted it… Unless the new kernel has the same problem as before (it better not!, heh), it made no difference.

Now I really have no ideas what it is… :frowning:

I have tested a theory and I beleive it’s the answer to why my InterWorx is so slow!

As I have a spare InterWorx license about to run out, I installed the same OS on VMWare, and installed InterWorx on that. Then I tested IWorx, and it loaded each page within 2 to 3 seconds, sometimes faster. Then I downloaded and ran two copies of Folding@Home, and set them to use 100% CPU… The load spiked up to about 10 and stayed there… I tried to load IWorx, and it took several minutes usually for each page to load. As soon as I stopped F@H, it was fine again.

Note this is all running on my personal PC, so network-slowness is not a limiting factor. However, I was using the same kernel version which gave my server so many problems, so this could account for the extra second of loading time or two every now and then.

Perhaps setting the IWorx init scripts to make it run at a higher priority would be a good idea… I would have tried this, but I don’t know how… yet :stuck_out_tongue:

Maybe the above idea could be added (as an option perhaps) to the installer script, or somewhere in NodeWorx itself? :slight_smile:

Not sure if this is it, but I remember there was something with HTTPS (SSL) pages running slower on my old RH9 box (Iworx and Client), i dont remember how i fixed it, but someone posted a solution on these forums somewhere… Maybe someone else reading this remembers what Im talking about. :confused:

Do you mean this?

Yup, that exactly what i was talking about, thanx again for that post so many months ago! :smiley: