PHP 5.2.6 with APC and MySQL 5.0.51

Located here in the vBullentin forums http://www.vbulletin.com/forum/showthread.php?t=274882

they say this

we recommend that vBulletin 3.7.x is run on PHP 5.2.6 with APC (or a similar opcode cache) and MySQL 5.0.51 for best performance and stability.

Currnently running IW 3.0.4 CentOS 4.6 and PHP 5.2.0 and MySQL 4.1.20

Will there be any known issues, or precautions to upgrade MySQL to 5.0.X and PHP 5.2.6 with APC?