php -v / Zend


If I run “php -v” I don’t see Zend Optimizer is loaded, and if I check on the phpinfo I see Zend Optimizer.
How can I fix this, that I can check it via php -v if Zend is loaded?

Its very urgent, because my billing system runs every 10minutes, and everyday few crontabs, and if I can’t see Zend Optimizer (at command: php -v) then de crontabs doesn’t work, because he said then: Zend optimizer is not loaded…

Please can somebody help?

If you look at the very bottom of /etc/php.ini you’ll see a few lines related to Zend. Copy these and put them at the bottom of /etc/php-cli.ini and /etc/php-cgi.ini if they exist and then restart apache.

But at the phpinfo i see that Zend Optimizer is loaded, also ioncube. but not at php -v…

EDIT: It works now, many thanks :slight_smile:

I understand. Phpinfo looks in /etc/php.ini and php -v looks in php-cli.ini or php-cgi.ini. Following the steps I gave you will fix the problem.

Great! Glad you got it fixed.

Stupid “phpinfo” :stuck_out_tongue: