Problem restoring account backups

Hello again, The problem we atre facing is that after testing on the server we formatted it and prepared it for production, backing up all accounts before formatting. After reinstalling, the server says that some files “are too big and you will have to upload them via ftp and backup from there”. The only problem is that we thought we could backup on a LAN server and then restore from there, but obviously some files are too big. Which is the file limit then?

The file limit is in the PHP max_upload_size variable. Basically, as a security precaution, PHP only allows up to a given size file to be uploaded via a form. This happens when you use the “Local Backup” option.

Is this the error message you are seeing?

“The file you are trying to upload is too big. You will need to upload the file to the server (e.g., via FTP) and use the Remote Backup File option.”

If so, what you need to do is transfer the backup file from the LAN server onto the production server. Make note of where you put the file. So for example, after transferring the backup file onto the production server, the file is located in /tmp/backups/, you would use the “Remote Backup File” option, and enter the path ‘/tmp/backups/’.

“Local” and “Remote” is a bit misleading here, as “Local” refers to the user’s local hard drive (the computer you are sitting at), and “Remote” refers to the server’s hard drive (the server running InterWorx).

The online doc may be a little clearer than I am :slight_smile:

Hope that helps,

Exactly, thats the problem. How about if to solve I change the variable value to a very high limit (like 2048MB) and after restoring, i change back to its original size? Do you think that’s a better idea than uploading via FTP?

Is there some reason why you don’t want to transfer the file (via FTP or even SCP) over to the new box? This really is the ideal way to import files greater than 1GB (or even 500MB) in size.

No, just for easyness. All our backups are on a local machine and we don’t want to be able to backup some (the small ones) and have to transfer others (the big ones). Could you tell me exactly which of the various php.ini files I have to change? TIA!

You could transfer all of them, small and large. The “Remote” option works on any SiteWorx backup, regardless of filesize.

The file you would want to edit is /home/interworx/etc/php.ini, though I’m not even sure that changing ‘upload_max_filesize’ would work. You will also need to edit the MAX_FILE_SIZE hidden form variable in the import.tpl template file of the theme you are using. This file
is located in (assuming you’re importing from NodeWorx):

/home/interworx/nodeworx/html/templates/<theme name>/import.tpl

MAX_FILE_SIZE is the Apache size limit, and upload_max_filesize is PHP’s limit, both of which need to be sufficiently large for a file upload to work. Even with these changes, I’m not sure if there are other variables you would need to change.