Problem with www vs. no www

Ok my first server with interworks is deployed. Working though some small issues with the dns. I have two test siteworx accounts. One of them will open the default cogg gears page with or without prefix www. The other site requires www or it will not open. Both domains are at the same registrar pointing to the same name server and on the nodeworx dns page have the same records. I think I ran into this years back on a cpanel site but can’t remember the details.

Any ideas?

Made some progress. I tested a few different browsers and for some reason this issue with this site only happens on Firefox. Site works with or without www on ie, chrome, safari, android etc. I tried a second computer and same thing this one test site with Firefox doesn’t resolve unless www. prefix is used. Of course my other test site with the same settings works without www on Firefox so I’m a bit puzzled.

------FIXED------ Deleted everything, siteworx and registrar and re added the accounts and now its working.

Hi simchippy

I would have thought it was dnscache in your browser or provider.

If this happens again though, please just look at the dns zone held for domain in IW if NS is fully pointed at IW, and you should see a cname and domain.url. If not or you prefer wwww and domain.url, please delete cname and create wwww standard A record.

I hope that helps

Many thanks