Qmail and Greylisting

I have a client that is sending email to a someone that is using a Greylisting email server. My client is telling me that the person they are sending to is getting lots of the same email. Like it’s going through, but Qmail is keeping it in the Que to send again.

Does Qmail handle the 45x SMTP error codes (or whichever one is a temporary try again later response)?

Some Links:


The other mail server has now been setup to let the domain in question passthrough. But Qmail for some reason keeps the message in the queue even after it has been sent out. So then it sends it again and again.

Any ideas?


Are you saying the message continues to be sent even after the greylisting server let it “passthrough”?

The first place I’d look would be the /var/log/send/current log file, to see what the receiving server is saying about the message.



Yes, the server admin added the domain in question to some sort of white list. I confirmed this by connecting to his server using telnet and everything worked fine.

When I send using my server the email stays in the Qmail queue. So its like the other guy is getting the email, but Qmail thinks that it didn’t go through so it keeps it in the Queue to try it again later.

When I looked in this log yesterday I found this:

 deferral: Connected_to_68.142.18.231_but_connection_died._Possible_duplicate!_(#4.4.2)/?

And searching for that IP in the log just now I found:

@4000000041fa5dd31d367a3c delivery 6847: deferral:
@4000000041fa5dd31d36a534 status: local 0/10 remote 1/255
@4000000041fa5dd514c5aa44 delivery 6846: deferral: Connected_to_68.142.18.231_but_connection_died._Possible_duplicate!_(#4.4.2)/

Whats the way you can “stream” the log file to the shell, I forget how to do this?

Thanks for the help,

I also get the following errors althought not sure if this is related.

@4000000041fa6408150a3cf4 warning: unable to utime remote/2/7848016; message will be retried too soon
@4000000041fa6408150a601c warning: unable to utime remote/22/7848013; message will be retried too soon
@4000000041fa6408150a67ec warning: unable to utime remote/13/7848027; message will be retried too soon

tail -f filename
will stream the log file to the screen as it grows

Just for kicks, edit the /var/qmail/control/timeoutremote file, and change the number to 100. Then restart the smtp service with

service smtp restart

I don’t know if that’ll help or not but if the timeout hits before the message communication is complete there might be a problem.


Paul I actually tried this, well I changed it from 10 to 30, but i’ll give it a try with 100. After I do a restart should i also do a service smtp doqueue to force the queue to try again with the new settings?

Thanks again Paul.

That was it. I dont know why I didn’t try something higher than 30 when I tried it the other day.

I should have thought about that again because when I telneted to that mail server after the DATA section I would send the terminating character and it would take about 30 seconds before i got the 250 response.

So it would take the message in, my server would timeout and put it back in the queue while his server delivered the mail to his inbox.