safe mode trouble !!


I run that script on site and discover no restrictions available on sites?
Any user can see any file around the server, copy or run coomands !!!


I try enable restriction but not work… ???

By defaul intewrox have safemode off on php.ini ?

Amazing !


If you want to enable safe_mode you should definately do that. By default when PHP is installed, safe_mode is off. If safe_mode was turned on, /etc/passwd would still be readable via a cgi script, for example. A large number of php scripts don’t function with safe_mode on, and if InterWorx turned it on, we would get complaints about that.

This is a decision left to the server administrator.


thanks mr, just amazing this option its configured to off.
I discover by accident, cpanel, ensim and all panels have that option configured to off, i asume interworx too, just that :slight_smile:

I undertsand not, and no complaint , just really suprise for me : )

best regards