scriptworx phpbb

PHP Fatal error: Cannot instantiate non-existent class: sql_db in /chroot/home/domain/ on line 60

This is after a fresh scriptworx install of phpbb.

What did I do wrong!? Other phpbb databases on this machine work.

Edit: I’ve just done a phpBB install via scriptworx on another domain and I get the same error as above.

Hi thegoat,

A google search for this error shows lots of possibilities as to the cause - possibly php or mysql version issue, or some problem connecting to the MySQL database. I tested installing phpBB with one of our test servers and couldn’t reproduce this issue so it doesn’t appear to a global scriptworx problem. It may take some more investigation to figure out what the actual problem is.


Well I haven’t done anything outside upgrades or installs of anything outside of the yum upgrades that InterWorx does automatically.

So the possibility of it being a php/mysql version error seems interesting.

Maybe i’ve inadvertantly done something without remembering. I’ll continue looking for a solution as well.


rpm -qa | grep mysql

Make sure all of the RPM’s are the same version. I had a similar issue once where the main mysql was one version and the mysql-client and mysql-server were different for some reason.


no dice :frowning:

Other siteworx stuff works fine with databases. only phpbb is messing up.

If you look at config.php in the phpbb installation, what does it have for the $dbms variable?


Actually you are running RPM’s for both MySQL 3.23 and 4.0 Ideally they should all be the same. Yes they wull work with mixed versions, I’ve dome that too.

I had an issue like this before and upgrading all of them to the new RPM’s fixed it for me. I don’t remember if it was phpBB or not.

In any event it can’t hurt. Of course I was on CentOS 3.x and you are on FC1, so I’m not sure if the RPM’s are available.

I did some poking ariund and didn’t find them on

But on


I did some poking around and found THIS rpm which I have but you don’t. Not sure what it is

you are also running both mysql and mysql-iworx

The second appears to replace the first at least on my boxex.

Anyway, it’s up to you what you want to try but here’s some other things to look at.

For the record this is what I have on My current CentOS box:

[root@iworx root]# rpm -qa | grep mysql
[root@iworx root]#

After checking the $dbms value was set to “”

Changed to “mysql” and it works fine.

Any idea why the scriptworx would leave the $dbms value as “” instead of “mysql” ?

works :slight_smile:

Thanks for the help again

If you can reproduce this case consistently, I’d be glad to take a look and see why ScriptWorx couldn’t determine the MySQL version properly. If you could open a support ticket I will take a look and hopefully we can prevent other folks from having the same problem. :slight_smile: Glad it’s fixed.