[sort of OT] libmysqlclient

Anybody got any ideas?

What is it and where can I get it for CentOS? It’s not on your Cent mirror.

The package perl-DBD-MySQL-2 has it as a dependency and I need to install that.


tim I think it’s a Perl module and you should install it with CPAM

Let me check, and then tell yu more

Hi Tim,

Our updated perl-DBD-MySQL package wasn’t up for centos, as you noticed. Try installing it now, via

yum install perl-DBD-MySQL

The reason it has to be updated is because of the updated newer version of MySQL we provide.


Thanks Paul. Worked like a charm.

This is what I am trying to do

[root@centos sympa-new]# rpm -ivh sympa-4.1.2-8.i386.rpm
error: Failed dependencies:
MHonArc >= 2.4.6 is needed by sympa-4.1.2-8
perl(DB_File) is needed by sympa-4.1.2-8
perl(MIME::Entity) is needed by sympa-4.1.2-8
perl(MIME::Parser) is needed by sympa-4.1.2-8
perl(MIME::Words) is needed by sympa-4.1.2-8
perl(Mail::Address) is needed by sympa-4.1.2-8
perl(Mail::Header) is needed by sympa-4.1.2-8
perl(Mail::Internet) is needed by sympa-4.1.2-8
perl(Net::LDAP) is needed by sympa-4.1.2-8
perl(SOAP::Lite) is needed by sympa-4.1.2-8
perl(SOAP::Transport::HTTP) is needed by sympa-4.1.2-8
perl(SympaTransport) is needed by sympa-4.1.2-8
perl(msg.pl) is needed by sympa-4.1.2-8
perl(parser.pl) is needed by sympa-4.1.2-8
perl(tools.pl) is needed by sympa-4.1.2-8
perl-CipherSaber >= 0.50 is needed by sympa-4.1.2-8
perl-DBD-MySQL is needed by sympa-4.1.2-8
perl-DB_File >= 1.73 is needed by sympa-4.1.2-8
perl-FCGI >= 0.48 is needed by sympa-4.1.2-8
perl-IO-stringy >= 1.0 is needed by sympa-4.1.2-8
perl-MIME-tools >= 5.209 is needed by sympa-4.1.2-8
perl-MailTools >= 1.14 is needed by sympa-4.1.2-8
perl-ldap >= 0.10 is needed by sympa-4.1.2-8
perl-suidperl is needed by sympa-4.1.2-8
Suggested resolutions:
[root@centos sympa-new]# yum install perl-DBD-MySQL
Gathering header information file(s) from server(s)
Server: CentOS 3.3 - Addons
Server: CentOS 3.3 - Base
Server: CentOS 3.3 - Extras
Server: InterWorx-CP - CentOS 3.3
Server: InterWorx-CP - Generic
Server: CentOS 3.3 - Updates
Finding updated packages
Downloading needed headers
Resolving dependencies
…Unable to satisfy dependencies
Package perl-DBD-MySQL needs libmysqlclient.so.10, this is not available.

I managed to install


but it still wants the other items. They are provided on their server but are built for RedHat 9. I tried to install these once before on my old server but IIRC only a hand full worked. I will try again on this machine and get back to you.

I thought about forcing the RPM install on the sympa package but am a little concerned because “We provide a RPM for RedHat 9.0 but it should also install well on older RedHat system” and this is CentOS 3 which is newer (Red Hat Enterprise 3).

I also thought about installing from source but decided against that too. Source will not tell me if I am missing something that it needs.

Any input would be welcome.

In case you’re wondering, sympa is a mailing list manager like mailman but with a much better web interface, very reminiscent of yahoogroups and the like.

Can you post the url of this software, and where those Redhat 9 rpms are? If they provide the source rpms you may be able to rebuild the rpms on your centos box, and install that way.


I’d say try to find RPMs if you can, I’m assuming that CentOS doesn’t come with some of these but may have others available. For each one just try:

yum install perl-<MOD NAME>

If yum finds it then you’re golden, if not then I’d say try to find other RPMs online. For perl mods you are usually ok with using another redhat version’s RPM since many perl mods are built for “noarch” and have a farily standard install structure.

If all else fails, fall back to source.


I posted during Paul’s post, and he points out a good idea. if SRPMS are available the rebuilt / install is trivial.


But won’t I still have problems with missing software (just no warnings that the software is needed) or does doing it from source negate that somehow (sorry for my ignorance).

[root@centos sympa-new]# rpm -ivh perl-MHonArc-2*
error: Failed dependencies:
perl(Unicode::MapUTF8) is needed by perl-MHonArc-2.6.8.tar.gz-1-1
perl(Unicode::String) is needed by perl-MHonArc-2.6.8.tar.gz-1-1
[root@centos sympa-new]# rpm -ivh perl-MIME-tools*
error: Failed dependencies:
perl(Mail::Field) is needed by perl-MIME-tools-5.411-1
perl(Mail::Field) >= 1.05 is needed by perl-MIME-tools-5.411-1
perl(Mail::Header) >= 1.06 is needed by perl-MIME-tools-5.411-1
perl(Mail::Internet) >= 1.28 is needed by perl-MIME-tools-5.411-1

[root@centos sympa-new]# rpm -ivh perl-MailTools*
error: Failed dependencies:
perl(Date::Format) is needed by perl-MailTools-1.61-1
perl(Date::Parse) is needed by perl-MailTools-1.61-1

[root@centos sympa-new]# rpm -ivh perl-SOAP-Lite*
error: Failed dependencies:
perl(MIME::Lite) is needed by perl-SOAP-Lite-0.60-1
perl(MQClient::MQSeries) is needed by perl-SOAP-Lite-0.60-1
perl(MQSeries) is needed by perl-SOAP-Lite-0.60-1
perl(MQSeries::Message) is needed by perl-SOAP-Lite-0.60-1
perl(MQSeries::Queue) is needed by perl-SOAP-Lite-0.60-1
perl(MQSeries::QueueManager) is needed by perl-SOAP-Lite-0.60-1
perl(Net::Jabber) >= 1.0021 is needed by perl-SOAP-Lite-0.60-1

[root@centos sympa-new]# rpm -ivh perl-perl-ldap*
error: Failed dependencies:
perl(Convert::ASN1) is needed by perl-perl-ldap-0.31-1
perl(XML::SAX::Base) is needed by perl-perl-ldap-0.31-1

I also need to find copies of perl-Digest-MD5 and perl-MIME-Base65 according to their site. RPM -q shows they are not installed (and they are not available from YUM) but we part of RH8. Could they be depreciated, replaced with something else?

Here ya go