Spamassassin Missing Modules

Hello,

I’ve checked which module was installed. I ran spamassassin in debug mod and had these missing modules :

[24657] dbg: diag: module not installed: IP::Country::Fast (‘require’ failed)
[24657] dbg: diag: module not installed: Razor2::Client::Agent (‘require’ failed)
[24657] dbg: diag: module not installed: Net::Ident (‘require’ failed)
[24657] dbg: diag: module not installed: IO::Socket::INET6 (‘require’ failed)
[24657] dbg: diag: module not installed: IO::Socket::SSL (‘require’ failed)
[24657] dbg: diag: module not installed: Time::HiRes (‘require’ failed)
[24657] dbg: diag: module not installed: Archive::Tar (‘require’ failed)
[24657] dbg: diag: module not installed: Mail::SPF::Query (‘require’ failed)

Does updates.Interworx provides these Perl module in a SRPM fashion (at least Mail::SPF::Query and Razor2::Client::Agent) ?

Why Interworx doesn’t install these modules ?

Thanks a ton

Pascal

Hi Pascal,

We only provide perl RPMs for the critical modules that SpamAssasin needs to run. Optional modules, like SPF and Razor2, are up to you to install.

Socheat