SSH Access for SiteWorx accounts?

Well, since the search won’t let me search on SSH (too short- damned minimum chars MySQL :smiley: ), I’ll make a new thread.

I’ve got a customer who needs SSH access to his account. He prefers SCP to FTP (and I don’t blame him), and he also has some fairly large SQL dumps he’d rather import from the command line.

I didn’t see an option in NodeWorx or SiteWorx to enable SSH access so I initially tried to create an account for him. I set his home directory to the directory of his site (/home/sitename), but he has no permissions to do anything in there. I noticed that the home folder sitename was also the username and owner, so I tried setting a password for that user and logging in under that, but got an account not available message upon logging in.

How do I add SSH access for my customer? He’ll need to have full read/write permissions for his site’s home directory (only), as well as access to the MySQL commands, and basic *nix commands (ls, rm, mv, vi, etc.), but I’d like to restrict him specifically to his home directory (/home/sitename).

Thanks for any help.

Hi Dave,

This is really pretty simple. First, determine the unix user that owns the files now.

Then, give the user a valid shell:
as root,
usermod -s /bin/bash <username>

Then, set a password for the user:
passwd <username>


Excellent! Thanks for the help Paul. I never even realized that the user didn’t have a shell associated with it. This fixed me up perfectly.

Thanks again!

They turn that off as a securyty precaution. Most SiteWorx users don’t need shell access.

Aye, perfectly understandable, and I don’t normally give out shell access, but this is a friend of mine, and he’s knowledgable enough about Linux to be able to use it without problem (He and I are actually starting a site dedicated to some Linux stuff - this was the site that needed the SSH access).


Well, that solution worked all well and good to give my user SSH access, but ever since I changed this, we are seeing 403 messages on everything in the html directory, even with the file permissions set to rwx rwx rwx. Any ideas?

Check the permissions of all the directories from / up to the html folder. Make sure the executable bit is set on all the directories.


Excellent! That did the trick. The domain directory directly above the html directory was only rwx rw- rw-.