SSI Help....

Ok I have a new client that needs SSI, and I have it on and working, BUT there are problems.

I have it on via Options +IncludesNOEXEC

If I have it on via Options +Includes including shtml files inside other shtml pages does not work.

<!–#include virtual="/rightmenu.shtml" -->
will not work

But if I have it set to Options +IncludesNOEXEC that will work but things like

<!–#include virtual="/forum/SSI.php?ssi_function=boardStats" -->

will not work.

How can I get them all to work right or is interworx not SSI friendly at all?

PS thanks for the help with the cPanel import!!

Looks like for some reason I can’t have SSI includes inside other includes… But they could on cPanel and I used to be able to in the past.

Haven’t done much with SSI in awhile, but there’s nothing special about the Apache that is installed on an InterWorx box that would make it “not SSI friendly”.

From the Apache cookbook (and probably somewhere in the Apache docs too):

Note that Options IncludeNoExec, in addition to disabling the #exec SSI directive, also forbids the inclusion of CGI programs using the #include virtual syntax.

So that would explain why IncludesNoExec won’t let you #include a PHP file.

Try setting it back to “Options +Includes” and check the permissions on the rightmenu.shtml file. See if doing the following fixes the problem:

chmod a+x rightmenu.shtml 

Ok did that and now the right menu does not work.

<!–#include virtual="/rightmenu.shtml" -->

Almost like there is something preventing includes inside includes. the examples for the SSI for the forums also shows a white page with Options +Includes.

Also the right menu does not show at all going right to it

Have you enabled the XBitHack directive?

[quote=IWorx-Socheat;11861]Have you enabled the XBitHack directive?[/quote]

Turning that on seems to have no effect on anything.

I have looked at every SSI thread on this forum and have tried all the tricks and its still not working right. Should I open a trouble ticket maybe?

Anyway it seems to be a “nesting” issue, on cPanel the client was able to “nest” SSI calls if they included an shtml page, but nesting doesn’t seem to work at the moment.

At the same time I don;t get why the pages calling php gp blank when set to Options +Includes but will show up with errors when set to Options +IncludesNOEXEC. Very weird stuff.