upgrade to MySQL 5


I hope someone can help, I just messed up my MySQL. I was on version 3.23.58-16 and needed to upgrade to v5.

I accidentally quit my terminal window to see what I did so now am a bit confused. Here is what I remember I did:

  1. first here is a current status of what is there.

I read on mysql site to upgrade to 4 first and then goto 5. So I force uninstalled the client and server rpm. There was still an iworx dependancy but didn’t do anything with that.

  1. Then installed the client and server MySQL packages with rpm command.
  2. I think I did this next /usr/bin/mysql_install_db a bunch of stuff happened.
  3. I think there was some problem with the socks connection.
  4. Then I decided to just get the 5.0 rpms installed and worry about the configuration when that was installed. When I tried to uninstall them it says they were not installed. when I tried to install the (version 4) rpm again (just to check i had spelling right etc.) it says they are installed.

I tried to start and stop using /etc/rc.d/init.d/mysqld start but that file is not there.

Basically, I tried to follow the guide from mysql for the upgrade but maybe something different is happening with iworx there?

Can anyone direct me to instructions on how to do this or help out in any way. that would be much appreciated.

I have centOS 3.6 (final)

Thanks in advance


I hope you didn’t delete the above package, as this is the MySQL server version that Interworx uses itself…

Nope didn’t delete that. The list is what is installed on the server at the moment.