Web Directories 403 Forbidden.


I’ve been pulling my hair out over this. I’ve been tinkering with the httpd.conf file for two or three days now trying to set up Apache so when you goto a directory like http://www.domain.com/random it will show a directory list. Under the default Iworx install it gives a 500 error. So I figured I would need to add in Indexes to the "home/*/public_html/ directive in httpd.conf. Did that and uncommented it. Still getting 403 forbidden.

Also… I seemed to have destroyed the module list Interworx provides. I removed the foo_module and all the other modules dissappeared. Yet they are all still active according to the server-information page.

Anybody have any suggestions?

Regards, Meddle

You can make a .htaccess file in the directory you’d like to expose with:

Options +Indexes

in it or put the same in the /etc/httpd/conf.d/domain.conf file as well



I wanted to do it globally. However, and luckily. I found what I was doing wrong and fixed it literally seconds before checking back here.

As for the Nodeworx Modules problem, any clue as to what I did there?

Regards, Meddle

Make sure your httpd.conf is chmod’d 644 and that should fix it.