Web Server Info Page not working

I was making some changes to the settings on nodeworx/http.php and the web server failed to restart. When investigating I saw some weird code right after the module loading in httpd.conf and ‘[ stuff ]’ which almost looked like a virtualhost directive. Apache would not start because of it so I removed it and restarted successfully. Now the nodeworx web server manager no longer works. All it shows is that the web server is online. No more module config or other settings.

Any ideas?

Ok, figured it out…

Typically, when InterWorx-CP is not seeing the Apache Modules or configuration values, this is indicative of incorrect permissions on the /etc/httpd/conf/httpd.conf file. This file should be chmodded 644 and owned/grouped root/iworx.
From this post http://www.interworx.com/forums/archive/index.php/t-1408.html

How the permissions were changed is beyond me… worked one min, changed settings and stopped working.

Now that I was able to get things working, I tried changing the “Max Requests / Server:” from 0 to a reasonable number, the error recurred. /etc/httpd/conf/httpd.conf is chmodded to 600 and “[VHOST :80 VHOST]]” is added right after the LoadModules directive.