YUM problem !

Hello,

We have a strange situation !

We’ve done an http centos5 i386 installation.

To do this e have booted on a centos5 cd (x86_64) and then choosed “linux text askmethod”
As method we choosed http
We selected the mirror and we’ve done a i386 centos5 installation (http://mirrors.ircam.fr/pub/CentOS/5.0/os/i386/)

Everything went well and we rebooted to the new centos5 OS

Uname -a give

uname -a

Linux liloo.carat-hosting.com 2.6.18-8.el5 #1 SMP Thu Mar 15 19:57:35 EDT 2007 i686 i686 i386 GNU/Linux

But when we do an yum update we have this error

–> Running transaction check
–> Processing Dependency: bind-libs = 30:9.3.3-7.el5 for package: bind
–> Processing Dependency: bind-libs = 30:9.3.3-7.el5 for package: bind-utils
–> Processing Dependency: krb5-libs = 1.5-17 for package: krb5-workstation
–> Processing Dependency: samba-common = 0:3.0.23c-2 for package: samba
–> Processing Dependency: nss = 3.11.5-1.el5 for package: nss-tools
–> Restarting Dependency Resolution with new changes.
–> Populating transaction set with selected packages. Please wait.
—> Package nss.x86_64 0:3.11.5-1.el5 set to be updated
—> Package bind-libs.x86_64 30:9.3.3-7.el5 set to be updated
—> Package krb5-libs.x86_64 0:1.5-17 set to be updated
—> Package samba-common.x86_64 0:3.0.23c-2 set to be updated
–> Running transaction check
Error: Unable to satisfy dependencies
Error: Package bind needs bind-libs = 30:9.3.3-7.el5, this is not available.
Error: Package bind-utils needs bind-libs = 30:9.3.3-7.el5, this is not available.
Error: Package krb5-workstation needs krb5-libs = 1.5-17, this is not available.
Error: Package samba needs samba-common = 0:3.0.23c-2, this is not available.
Error: Package nss-tools needs nss = 3.11.5-1.el5, this is not available.

As you can see it set to be updated soe x86_64 bits packages !

–> Package nss.x86_64 0:3.11.5-1.el5 set to be updated
—> Package bind-libs.x86_64 30:9.3.3-7.el5 set to be updated
—> Package krb5-libs.x86_64 0:1.5-17 set to be updated
—> Package samba-common.x86_64 0:3.0.23c-2 set to be updated

These packages are not install, as it is the i386 versison that is installed

yum list nss

Loading “installonlyn” plugin
Setting up repositories
Reading repository metadata in from local files
Installed Packages
nss.i386 3.11.5-1.el5 installed

Available Packages
nss.i386 3.11.5-3.el5.centos updates
nss.x86_64 3.11.5-3.el5.centos updates

Do you understand why it tries to install the x86_64 bits version ?
Any idea ?
How to change this ?

Pascal

Really strange

I have modified /etc/yum.repos.d/CentOS-Base.repo and rather let it find the arch I have set it to i386 !!!

[base]
name=CentOS-$releasever - Base
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
baseurl=http://mirror.centos.org/centos/$releasever/os/i386/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5

#released updates
[updates]
name=CentOS-$releasever - Updates
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates
baseurl=http://mirror.centos.org/centos/$releasever/updates/i386/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5

Do you know how yum defined &arch=$basearch ?
I have looked in /usr/lib/rpm/macros and %_arch is well set to i386 !

I have no idea how yum define the arch !
Any idea ?

Pascal

Hi Pascal,

A little confused here. Are you trying to install InterWorx on a CentOS5 server? Or is this just a general CentOS5 question/problem?

Socheat