aack, child crashed (on send/receive)


I run Fedora C4 with InterWorx. When I send/receive email (qmail) I get the error.

“aack, child crashed”

I’ve done some research and the fix is in this topic:

However I’ve tried to change the password using SiteWorx and it still happens. Has anyine else had this problem. I’ve even added/removed the accounts.

Whats odd as it does send/receive email and this error seems to be erratic. :frowning:

Hi Brooky,

Try upping your softlimit in the following files:


Look for a line like this:

exec /usr/bin/softlimit -m 6400000 \

and increase it. We typically just add a 0 to the end. Be sure to restart those services after you’ve made your changes.


Hi brooky,

Try increasing the pop3 memory limit. You can do this by editing the file:


and changing the number


to something higher, for example,


Then restart the pop3 service via

service pop3 restart


Damn, socheat wins thsi round.


All are set to 25600000 and have been restarted. Same old problem. Silly server. :stuck_out_tongue:

Thats 256Mb I think. :-/

Server has 1GB ram.

Did you use that fix mentioned in the qmailrocks link you provided? If so, I would suggest deleting the email accounts again and re-adding them. We’ve seen for some clients, simply doubling the softlimit works. For others, they had to increase it by more than 10x. YMMV. :rolleyes:


Yeah I removed the account and added again and changed the memory. I removed the accounts and added them a week ago so I’ll try again now the memory has changed. :stuck_out_tongue:

Will post back the results. Thanks for all your help kind sirs. :slight_smile:

I just can’t resolve this one. I’ve deleted the email accounts and added them again. Reset password but it just still happens.

Does anything look unusual in the attached screenshot?

Could this issue be Iworx related as I’ve found another IWorx user with the same problem?Seems a little coincidental:


I’ve had this problem for months now.


It may be an “iworx on FC4” issue but I can’t seem to reproduce it on our FC4 box and haven’t heard anything similar on other distros we support. The mem limit bumping that the other guys suggested was what I would have said as well but after 256M I doubt that bumping it more would help. Is there any consistency at all to this?


Hi Chris,

Yesh it’s completely consistent. It happened all the time and nothing I’ve tried makes a difference at all. If I click send /recieve using Thunderbird the message comes up although email comes in sometimes. It will throw the error even if there is mail in the box. Outlook throws a similar error message.

It’s not a drastic problem, just a little annoying. Thansk for getting back to me.

I would sell my soul to the devil in exchange for a peanut and wipe his backside to resolve this one.

The problem has been happening since May :frowning:

Sometimes I get a prompt for my login password too which is wierd. I’ve scoured the internet for a solution.

Hi Brooky,

Is it happening with all accounts on the box, or just certain accounts? Are you using pop3 or imap? If you open a ticket with all the related information (root login, nodeworx login, an email account this is occuring on w/ the login information), we can take a peek.


It’s happening with all accounts that are POP 3. I’ll try a new IMAP account before submitting a ticket. Thanks for replying. :slight_smile:

I had the memory limit at 25MB rather that 256MB. I’ve now set it at 128 and all is working great. :rolleyes:

Thanks to Paul on support for sorting this for me. I feel rather silly. :smiley:

For the record 128 MB = 128000000 Bytes (Six zeros)