Activation Error: Database Setup Failed : Error 1091, Can't Drop 'idx'

I’m in the process of moving to a new server. Install of interworx on the new server went perfectly. I then switched my license IP to the new server IP and tried to activate. That is where I am having a problem.

I did submit a support ticket already, 14 hours ago, and just hoping that I might get some help faster via the forums.

I switched my license IP to my new server’s IP, then tried to activate first a few times via command line then tried via the web CP.

Details from command line activation attempt:

ERROR 1091 (HY000) at line 225: Can't DROP 'idx'. Check that column/key exists
| Setting up SpamAssassin DB... |

[ERROR] Database setup failed. Please contact InterWorx Support.
[ERROR] Activation Failed
[root@colo bin]#

And details from failed activation via web CP:

[STATUS] Go! InterWorx
[STATUS] License Key Setup...
[STATUS] Validating license information...
[STATUS] Setting up PHP-CGI...
[STATUS] Setting up initial InterWorx Databases...
[WARNING] Looks like iworx was setup before on this box...
[WARNING] Problem setting up DB info. Trying again...
[STATUS] Setting up initial InterWorx Databases...
[STATUS] Setting up iworx DB...
[STATUS] Setting up FTP DB...
[STATUS] Setting up Horde DB...
[STATUS] Setting up Roundcube DB...
[STATUS] Setting up SpamAssassin DB...
[ERROR] Database setup failed. Please contact InterWorx Support.
[ERROR] Activation Failed

The part where it states “looks like iworx was setup before on this box” is there only because I’ve had to try to activate multiple times. That message was not there the first time. Just wanted to be clear that this is a brand new server install with a fresh install of iworx.

Please let me know if anyone has any ideas on how I might correct this issue so that activation can complete.

Hi john2k

I hope you don’t mind, as I have quickly read your post sorry, but please be aware of time differences for interworx, which I’m sure they’ll reply to ticket ASAP.

I’m thinking your server cannot communicate with license servers, but I’m not too sure as your log shows contacting license server, then continuing, but I’m just thinking if you have routed any ip, which is still routing replies back to the old server.

I know there’s a command you can try, but I’ll have to look it up, which I’ll post here later, but it might help other users if you could let everyone know your operating system.

I’d also check the firewall, to make sure all ports needed are open, and check your MySQL is running.

Lastly, have you restarted your server

I’m sure you may have already considered the above, and I apologise in advance.

Many thanks


Hi john2k

Sorry, I’ve had a quick look on tapatalk, and I think the command I was trying think off, but memory failing was yum update.

This is just to ensure you have the latest packages

Again, please accept my apologies if you have already done this.

Many thanks


Hi d2d4j,

Communication with the licensing server seems to be fine as I can ping, which was the troubleshooting recommendation in the documentation.

As you suggested, I rebooted my server, verified that MySQL is running and ran a yum update (which only had 1 updated package for roundcube). Tried to activate again and still fails with the same error.

On the web based activation/installer, immediately after I click to start it I get the following message:
“Problem Setting up DB info. Trying again…”

Following that message a few other things are done, but at the end it states “Activation Failed.”

When I try activating via command line, the following error is what comes up:

ERROR 1091 (HY000) at line 225: Can’t DROP ‘idx’. Check that column/key exists

Forgot to post this in my last reply. I’m running the most recent version of CentOS, 64-bit CentOS version 6.4.

Hi John2k

I’m thinking perhaps it might be a permission issue then.

I remember your other post about having 2 /home setup, and I’m wondering if you have already sym linked these, if so, perhaps that might be the reason for failure, and/or if you setup you drives with enough space perhaps.

I might even if needed quickly, uninstall Interworx and rerun installer again, but this would just be to make sure there were no errors (but you have already stated this installed without issue).

I’ll have a think more but hopefully you may have had a reply to your support ticket.

Many thanks


That is with my current/old server that I’m moving away from. It’s really a separate issue as I haven’t even started with transferring sites over to my new server (where I’m having this issue with iworx activation).

Correct. When I installed iworx on my new server there were no issues at all. The problem I’m having is with the license activation process in which I tried both the goiworx.pex script as well as via the web control panel.

Any idea where / what I would check?

With the error being “ERROR 1091 (HY000) at line 225: Can’t DROP ‘idx’. Check that column/key exists” it seems to look like dropping a table or something (‘idx’) from a database, but I’m not sure if that would be within the default MySQL install or maybe some other internal database to interworx.

No replies yet in over 17 hours.

I don’t mean to sound overly critical of how long it’s taking to get my support ticket replied to. I just want to be able to move forward with the work I need to do and I cannot do anything until this iworx install is activated.

I just ran updatedb then “locate idx” since ‘idx’ was mentioned in the error message. Only one item came up in that search:


I have no idea if this has anything at all to do with the iworx activation issues I’m having, though.

Hi john2k

I understand your frustration, and it is more likely a time difference delay but I don’t know where you are in the world. I think my time difference is about 8 hours or more, which given time frames from close of business to opening, could account for a lot of the time delay.

I’m sorry, perhaps your not aware, I don’t work for interworx so it’s only my thoughts, and posting to the forum for a quicker response, may or may not be any quicker or give resolution sorry.

I do know interworx uses it’s own seperate MySQL, php etc… And your idx found relates to SSL, but I’m not an expert and wouldn’t know if this was the initial SSL used.

I would be patient as I’m sure interworx are looking at this, and perhaps some of your posts here may help before replying to your ticket.

To be honest, if it were myself and I needed this very quickly, I always do a clean reload of os and interworx, just in case there were failures I wasn’t aware off, it usually works but this is my personal way.

I’ll have a think though and I’ll load a test server over weekend to see if it gives the same for myself, which we use centos 6 64 bit.

Hope that helps a little

Many thanks



Thanks for your all of your help. When you mention time difference delay and business hours, that implies interworx doesn’t have 24/7 support. If that’s the case, then my mistake. I was thinking that interworx had 24/7 support available with this being a fairly major control panel.

In any case, it seems as though iworx support is on to my support ticket now so hopefully will be resolved soon.

About the clean os & iworx reinstall, that’s how I started out, on a fresh install of CentOS 6.4 64-bit followed by installing interworx. Anyhow, hopefully the support techs will be able to get this all sorted out.

Thanks again

Hi john2k

I’m sure they will, they rock.

I would think they may do 24/7 support but at a cost, as we do as we need to pay for it, but in general terms, I don’t think interworx really goes wrong, certainly in almost 2 years, I’ve never seen it go wrong apart from some os updates which caused an issue, but a server restart resolved it.

I hope your soon up and running and please feel free to post on any issues, I know there’s good people on the forum who can help or try too, but it’s world wide so time differences do play a big part in delay.

Many thanks


The primary failure source here was that John had skip-networking specified in /etc/my.cnf, and iworx uses a network-based connection (albeit to to do database setup during initialization. So, we commented out skip-networking, and also moved the data directory and socket in my.cnf back to where they originally were. InterWorx is fairly rigid about the placement of some files and directories during setup, hence why we recommend running it on a fresh, untouched CentOS / RHEL / SciLinux system. You should do customizations like this after you run initial setup.

So, we ran setup and it succeeded. After setup, we moved /var/lib/mysql to /hdd2/mysql , then set up a symlink from /var/lib/mysql to /hdd2/mysql . InterWorx is ticking over fine now here.

I’ve submitted a bug report for the inability to drop ‘idx’. I note that this tells me it’s not a setup-blocking failure and that table gets regenerated anyway during roundcube setup.

I was just stopping by again to update this thread for anyone who comes across in the future with the same issue. Robert beat me to it, though. :slight_smile:

Robert, thanks for updating this thread & explaining what the issue was. I appreciate all your help.

In case anyone is curious, I had turned skip-networking off since this is a single server setup… no need for external servers to be able to connect to my MySQL on this server (makes things a bit more secure, even if only minimal). Also, I’ve read that using sockets with MySQL is faster than via networking. Probably just comes down to milliseconds, but I still wanted to go with the faster socket option if possible.

And the mysql data directory being moved was so that MySQL would get all the performance of the secondary hdd.

I agree about interworx not going wrong. Even with this issue it was my fault for setting the mysql configs prior to install rather than after installing. I’ve been using interworx for a few years now and have been very happy with it.