adding ssl certificate to siteworx domain ??

i have a ssl certificate for one of my domains, i have read through the forum but need to ask as a lot relate to installing using ssl option in siteworx account.
i have enabled the ssl option for the domain but don’t see the option in the account, is this because the domain shares an ip ??
Tried enabling the option on one of my domains which is set dedicated but that still did not show the option in the account.

anyway how do i setup the ssl certificate manually for the domain i want to use it on ??
do i add to /etc/httpd/conf.d/

SSLCertificateFile /etc/ssl/crt/yourDOMAINNAME.crt
SSLCertificateKeyFile /etc/ssl/crt/private.key
SSLCertificateChainFile /etc/ssl/crt/

If so could you confirm where i put this code and also the best place where to put the files, at present the path is default for my setup ??

Thank you

If you wish to run SSL, you must have the account (domain etc) on a single, dedicated IP Address, with no other accounts using it. Then the SSL link should automatically show in SiteWorx.

Your right with the SSL Cert as to where you put it… but you have to double up the host config information to allow it to run on port 443 for the domain, before adding the SSL info. You’re best bet is to probably get it working through SiteWorx. :slight_smile:

ok got the ssl option in the account of the domain.
used the migrate existing ssl data option
added private key
csr that i used to supply the ssl cert provider
added ssl cetificate.

i checked the domain config and it added
[I]SSLCertificateFile path to domain ssl /DOMAINNAME.crt

SSLCertificateKeyFile path to domain ssl/private.key[/I]

i also had a file which i put in the ssl directory and added
to the domain conf :- SSLCertificateChainFile path to ssl/

restarted apache but still did not seem to work as i get this usual on both &
[I][SIZE=2]There is a problem with this website’s security certificate.[/SIZE]

not sure what else i have to do now, do i have to add anything else to get this working
thank you


anyone please ???

You should remove what you added for the cert and instead add it via siteworx in the Manage Chain Certificate page. Try that.

nope that didnt work either and still get the error and no padlock
[SIZE=2]There is a problem with this website’s security certificate[/SIZE]
[SIZE=2]will have another look, should be straight forward really.[/SIZE]