Advice Needed: Installing with FC4


We are bringing an Interworx box online in the next few days (we currently use FC3 across most servers), and the client has requested FC4. However he does not want PHP5.

He would like, PHP4, Mysql 4.1.x & Apache2.

Please can someone give some details on the “best” way to ‘downgrade’ the PHP that will be installed by Interworx?

Many Thanks, and looking forward to your responses. :slight_smile:



I’ll have to face this very same problem this week (waiting for a server to be put online), and I’ll try myself if nobody answers :wink: I’ll let you know the results… I’ve been fighting mysql 4.1.x, 4.0.x and 3.23.x with PHP for some time now.



This is the easiest way I know of guys:

  1. Install IWorx-CP as “normal” (i.e. with default fedora PHP5)
  2. Remove the PHP package that fedora provides (DO NOT REMOVE THE PHP-IWORX PACKAGE) using rpm -e <pack names>
  3. Edit your /etc/yum.conf and put an exlucde in there for php. This will ensure that next time YUM runs it won’t clobber the work we’re about to do with the “newer” php5 default RPMs
  4. Run the following command:

rpmbuild --rebuild --with fdr40

You may have to install rpm-build and gcc (using “yum install gcc rpm-build”) if the previous command gives you issues. If the RPM complains of missing dependencies (of which there are a ton) you may also have to install all of them. If you can’t find mhash/libmhash look here:

  1. Once that completes you’ll have a bunch of new RPMs in /usr/src/redhat/RPMS/i386 or /usr/src/redhat/RPMS/x86_64 depending on your architecture. Just rpm -Uvh <packages you want installed> and that should do it


Hello. I finally setup a FC4 box with PHP4 + MySQL 4.1.

I tried the guidelines provided by Chris, but rpmbuild won’t make it compiling PHP4 from src.rpm on FC4, perhaps some GCC version issues or whatever. I read that some other people faced the same problem and tried a proposed solution: just using the FedoraCore3 PHP4 rpms.

This worked for me, just had to resolve some dependencies.

So this is the briefing:

  • Install Interworx-CP as normal on FC4 box.

  • Uninstall rpm packages for installed php5

rpm -e --nodeps php-pear php-mysql php php-ldap

  • Getting php4 FC3 rpm packages:

mkdir /root/downloads

cd /root/downloads










-Installing compat packages needed:

yum install

-Install PHP4 from rpms you just downloaded:

rpm -ivh php*


php -v

PHP 4.3.11 (cgi) (built: Apr 25 2005 22:06:33)
Copyright © 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright © 1998-2004 Zend Technologies

After that I installed as normal Zend Optimizer, and test a “phpmyadmin” installation with no problems under Apache to test MySQL and PHP.

-Put a exclude on [main] section of /etc/yum.conf:

I assume this will prevent php-iworx to be updated if someday needed, so perhaps Chris can point out something about this exclude?

Hope this helps someone.


Thanks for posting this Juan! I’m sure it’ll help a bunch of folks.


I also have to add something about the firewall on Fedora Core 4.

I had to disable the redhat firewall enabled by default in my FC4 installation in order to make APF work correctly (they get “mixed”). By default, this disables responses to HTTP, FTP, etc.

So you have to select “Disable firewall”, executing /usr/sbin/setup (it’s a console app), and then start APF.

I had locked myself but having a “Trusted IP” saved me from a reinstall and now it’s working nice.



There is also quite a problem with APF and the Kernel that FC4 comes with, meaning APF wouldn’t work at all. There is a fix which I will details shortly however it is only a temporary fix to get the firewall “functioning”.

Yeah you’re right. I forgot it. Those are the APF issues with 2.6 kernels and I have the temporary fix put on too.