Allowed SMTP IP Based Relay getting blocked by RBL

I setup a client’s Exchange server to use my Iworx server as a SmartHost. I’ve setup the tcprules to allow their static IP to relay through my server, but they got on a blacklist that my server blocks and it’s not letting their emails out.

Is there a way to also whitelist their IP from the blacklist at a global level?

Hi justin

I hope you don’t mind and I’m sure you’ll have had a look, but I believe there are 2 ways you can do

Set the ip as a whitelist in spam assassin nodeworx, system services, mail, spam assassin

And or

Add a spam assassin whitelist globally from same menu

I’ll check when I’m back though later and apologise if I’m wrong, it’s just off too of my head.

Hope that helps

Many thanks

John

Hi Justin

Sorry, I was quicker then I thought, and please see pics, both are the same menu from nodeworx.

Please be careful not to choose whitelist_recd, as this stops the check on incoming email from a particular domain/email address.

Also, you may want to add the IP to the spam assassin trusted network, if you have not done already as well, to cover all bases.

I hope this helps and I’m sorry if I’m wrong

Many thanks

John

Hi Justin

Opps, sorry, I had selected the wrong field, you need whitelist_from, not unwhitelist_from sorry.

Many thanks

John

Hi Justin

I’m so sorry, I have edited my original post as whitelist_from is not available as an option from drop down box, but it is the set as the picture displayed. Both of these are the same i.e whitelist_from.

Also, I hope you don’t mind, but you have indicated if it is your iworx server blocking at rbl or if it is a receiving mail server your sending to, which is blocking. If the latter, I think you will need to clear the headers as a lot of mail servers will check on sender originator details.

Lastly, and it’s off the cuff, so please feel free to ignore, but is the client etg by any chance.

Many thanks

John

This is just a small business IT client of mine. To try and help them out I setup their Exchange to forward (Smarthost) to my server to hide their blacklisted IP while I try to figure out which workstation is infected with the SpamBot.

So basically I just change the TCP Rules for the SMTP server to allow relaying from their static IP at the office using this method:
http://forums.interworx.com/showthread.php?78-Qmail-Allow-relay-for-a-specific-IP-address

The problem is the main SMTP level “Realtime (SBL) Blacklists” SpamCop is blocking their email. For now I just disabled the SpamCop blocking at SMTP level, but was wondering if there was a SMTP level way to whitelist an IP.

I’m not sure the SA settings will be able to get around this block in this specialized “smarthost” setup, but I’ll have a look.

Thanks for your feedback.

Hi justin

Many thanks, I’ll have a read if that when I’m finished later.

My initial understanding of enterprise mail servers is the mail server hands off to a filter, either at connection time and or once email has been received but prior to flushing the spools to accounts etc…

I think as spamcop is auto set in SA it is here where it is been used.

Also, just a thought, have checked with other rbls, if listed at spamcop, it’s likely it’s listed with some more rbls. We use dnsstuff.com to check.

I’m sorry if I’m wrong and I hope it helps.

Many thanks

John

Hi Justin

I’m so sorry, the penny final dropped, and MTA has it own rbl check, sorry.

On your forum link provided, you need to add the following to the end of ,RBLSMTPD=""

so it reads

22.22.22.22:allow,RELAYCLIENT="",RBLSMTPD=""

This then allows relaying, with no RBL checks but if you want to allow with no RBL checks but not relaying, you add a line like this, 11.11.11.11:allow,RBLSMTPD=""

Clearly follow all instructions on the forum post you listed, and restart I think Qmail, and you should be good to go.

I hope this helps, and please forgive me for getting confused over SA.

Many thanks’

John

I’ll have to give that a try. Thanks for taking the time to look that up for me.

I hope you don’t mind, but you have indicated if it is your iworx server blocking at rbl or if it is a receiving mail server your sending to, which is blocking. If the latter, I think you will need to clear the headers as a lot of mail servers will check on sender originator details.

Off topic, but I dig the website in your signature. Pretty website. Did a good job :smiley:

It was my iworx server doing it at the SMTP level (since it was just relaying it). Once I remove the list from my server settings emails sent fine.

I never tried the other helpful suggestion by John, 22.22.22.22:allow,RELAYCLIENT="",RBLSMTPD="", since it was just a temporary setup and I was about to take it down anyway.
But I will know for next time. Thanks again John.

Thanks! Thought it was a fun way to present our info.