I’m trying to install the FrontPage extentions again:

Getting User from /etc/httpd/conf/httpd.conf
Unix user name of the owner of this new web: [apache] frontpag

Getting Group from /etc/httpd/conf/httpd.conf
Unix group of this new web: [apache] frontpag
Installing root web into port 80…

installing server / on port 80

Will chown web to frontpag as part of install.
Will chgrp web to frontpag as part of install.
Error: FrontPage requires that the AllowOverride option be set to something other than “None” (typically set in access.conf). “All” is the preferred AllowOverride option for the document root.
ERROR: / installation failed.
Hit enter to continue

Exiting due to an error! Please fix the error and try again.

[root@centos version5.0]#

What can I safely set AllowOverride to?

Also, I don’t have an access.conf file but I Do have this listed in several places in httpd.conf Whuch should I change?

Can I add an allow override value to an existing domain.tld.conf file and then specify that where it asks for the server conf file instead of httpd.conf since ideally I’d only like to make this change to domains absolutely I have to?

When I give it an individual conf file in this case, it ignores it. I am assuming it is looking for the AllowOverride value.


PS I am documenting what I am doing and intend to share when/if I get them working :wink:

in /etc/httpd/conf/httpd.conf

I have

AllowOverride controls what directives may be placed in .htaccess files.

It can be “All”, “None”, or any combination of the keywords:

Options FileInfo AuthConfig Limit

AllowOverride None

Should I edit AllowOverride from None to Limit or something else?

Are you saying you tried editing the vhost and put the AllowOverride All in there, and it still didn’t work? Even after restarting Apache?

My initial guess would be, that should make it happy when you go to install the extentions.


no, I’m asking the best way to proceed:

  1. edit the main httpd.conf file
  2. add an access.conf file with that in it (and where)
  3. add it to the file

(sorry this wasn’t clear)

Also should I use “All” or “Limit” or something else; the FP script just says I can’t use None

Part of what is confusing is that it is asking for the “server config file” not site config file and I am creating the “root web” that FP needs. I’m not sure if I can have more than one root web.

Ideally I’d add a root web in /home/ or /etc/www/html/ and create the subwebs elsewhere, but for now I just want to get it working. The domain I listed here was created for the sole purpose of testing this install.

When I got this working before I only needed it for one site so I never went further with it. Now that I get into it again I thiink the AllowOverride was the problem before, but I’m not sure how I fixed it.

I’ve tried adding

AllowOverride Limit

to several places in the file and every time I run a config test I get the errors:

[root@centos version5.0]# service httpd configtest
Syntax error on line 11 of /etc/httpd/conf.d/
AllowOverride not allowed here
[root@centos version5.0]# service httpd configtest
Syntax error on line 5 of /etc/httpd/conf.d/
AllowOverride not allowed here
[root@centos version5.0]# service httpd configtest
Syntax error on line 1 of /etc/httpd/conf.d/
AllowOverride not allowed here
[root@centos version5.0]#

Is there a specific place I should add it or do I need to add more than that simple statelement?

I think option 3. Something like

<Directory /home/<user>/<domain>/html>
AllowOverride All

inside the vhost.

I’ve only seen setups with root webs installed on each domain that has FP extentions installed.

That’s one of the places I tried to put it and it wasn’t allowed


SuexecUserGroup frontpag frontpag

DocumentRoot /home/frontpag/

AllowOverride Limit

I tried it editing the main httpd.conf file and had some success (ran into another error) and am not sure I like changing this globally.

I assume the None is inthere for a reason (security).

Gotta get some sleep now, but wil look at it again in a day or two, any further thoughs are welcome.

I don’t feel too bad having problems here, I understand the Allmanaged team tried this for a client and gave up. If I get this working, I’ll send them my notes.

Thanks for everything Paul :slight_smile:


I trued doing thos by changint it globally and installint the “root web” as the default in the httpd.conf file byt ran into problems with setting up “new sub/per-user webs” because the values set in httpd.conf did not make sense to the script, but that’s okay.

Then I tried setting subwebs ans ran into problems there: if I use httpd.conf as the server config file it says the subweb I tried to set up is invalid (I assume since it’s not defined as a virtual web in that file. If I use then it ignores it as a config file just as before since (I assume) it does not have the AllowOverride value specified. I guess it’s back to finding a way to put that in there that will not be rejected by apache during a configtest.

Willl keep you updated.


I added

<Directory /home/frontpag/>
AllowOverride Limit

not just the AllowOverride statement even though the directory is also incuded (specified as DocumentRoot) elsewhere in the document.

This new configuration shows:

[root@centos version5.0]# service httpd configtest
Syntax OK
[root@centos version5.0]#

Going to try again

Will chown web to frontpag as part of install.
Will chgrp web to frontpag as part of install.
Error: ‘/home/frontpag/’ server is not a valid virtual server.
ERROR: / installation failed.

It still ignores it when I specify as the server config file in the subweb section and I get the above from using httpd.conf

Any other ideas? what else should I add to the virtual file to make it detected as a server conf file.

This is what it spit at me when I originally tried to create a user/subweb:

Install new sub/per-user webs now (y/n) [Y]? y

Using FrontPage Configuration File: /usr/local/frontpage/we80.cnf

Getting DocumentRoot and UserDir.
Getting resource configuration file
Directive ResourceConfig not found.
Getting DocumentRoot from /etc/httpd/conf/httpd.conf
Getting UserDir from /etc/httpd/conf/httpd.conf
does not exist!/htdocs"
ERROR: Unable to get DocumentRoot/UserDir

Any ideas?

copied this from the httpd.conf

UserDir: The name of the directory that is appended onto a user’s home

directory if a ~user request is received.

UserDir public_html

Control access to UserDir directories. The following is an example

for a site where these directories are restricted to read-only.

#<Directory /home/*/public_html>

AllowOverride FileInfo AuthConfig Limit Indexes

Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec


Order allow,deny

Allow from all



Order deny,allow

Deny from all



What parts should I /could I add without causing problems? Not sure how to use this on a virtual host; ideally i’d dump the idea of a userdir alltogether and give all users access to the root of the site:



Just to update anybody who may be wondering how this is going. I didn’t get a chance to work onthis on Sunday like I wanted but it’s something I am still doing. I am doing some apache research to see what I should add to the domain.tld.conf file to make nice wth apache (see the previous post). I’ll keep you informed.