Any one have issues with the Mac iweb and seeing Â, ’ characters?

I have some one using iweb, Mac program, on my IW 3.0.4 CentOS 4.7 server. After uploading their html page they are getting these ?, ’ characters. The html pages that are being uploaded are using “charset=UTF-8”

In my research I did run across this Mac page addressing this issue

Here is a statement from that page

If a page you create in iWeb and publish to a server other than .Mac contains strange unwanted characters, try setting View > Text Encoding in your browser to UTF-8. If this makes it appear correctly, it means your server is probably forcing browsers to interpret the page as being in Latin-1 encoding. iWeb pages are in UTF-8 encoding so that they can accomodate all languages, not just English and those of W. Europe, and there is no practical way to change this.

Well I tried that and the ?, ’ characters went away.

Now since this is a server setting issue, does anyone know where to go to make a change server wide to allow UTF-8 without effecting other sites settings.


Would this best be done with a .htaccess for this one particular web site?

Thanks guys for any and all help.

With some further research I found this page that address’s this issue.

So, now my question is, if you had this problem what did you do, set up a .htaccess file for that specific SiteWorx site, or change the setting server wide to allow UTF-8 to be used server wide?

If server wide, what file did you change?

I would suggest the .htaccess route - you may cause issues with other sites expecting the current default if you change it server wide.

Charsets are such a nightmare…but standardizing is nearly impossible too!

I will give .htaccess a try for this site, thanks Tim.

I attempted to use the Directory Options function in SiteWorx, (specified a directory) and used the Default Character Set to set the following Default Character Set “UTF-8 .html” and got a error, invalid, then tried “UTF-8 html” without the dot and same error. Could only use “UTF-8”

So I set it as UTF-8 and nothing changed on the problem pages. So I manually changed the .htaccess to UTF-8 .html and still no luck.

Anyone else that might have had these same issues and you found a solution, I would love to hear from you.

I will continue to work this problem.