Anyone Testing Modernbill 5?

I’m testing Modernbill 5 now, but can’t get the Interworx module to function. Can anyone confirm that it works?

I believe you need MB5.1 for it to work. Since they (ModernBill) wrote the module this time, I’d recommend you post to their forums or open a ticket with them as they are much better equipped to help you than anyone here.

I have opened a ticket with them. The question here is whether anyone has been able to get it working yet.

Actually, it is a Interworx issue, sort of.

Didn’t mean to be so snippy Tim, if you’ve been to the ModernBill boards, you’ll see that dealing with ModernBill v5 tends to bring out the worst in people :slight_smile:

The reply from the ModernBill team (below) indicates something went wrong during the apache build, which Interworx did for me when I purchased the licence, so I’m going to open a ticket here at Interworx and hope for the best.

License: 850380807 (2006-12-04) 22


It looks like your PHP is missing the xmlrpc extension that is needed to run their external API. I can see in your phpinfo page: ‘–with-xmlrpc=shared’ , but the module is not getting loaded. It’s possible that you would need to add that library to your system before it does.

We were able to use your API key on a local install to get a good connection. Note in the module config how we put the URL in - no https, and no path after the domain. Once you get that library installed and restart Apache, your phpinfo page should show that extension installed.

~Mark Garrett
~Quality Assurance Engineer
~ModernGigabyte, Inc.

Sorry for the delay, hubbadubba. I just responded to your ticket.


Thanks- works like a charm after you ran the yum install php-xmlrpc. I saw package headers while poking around, and just assumed it was installed already.

Not at all, hubbudubba, we all get get frustrated with software at times and I’m just glad you got your problem worked out. :slight_smile:

I’ll just add here for you and anyone else reading that an easy way to make sure you have all of the php RPM’s installed is

yum list | grep php

which will list all of the available packages with php in the name and tell you if it is installed or not.

This won’t gurantee every single function of php is there, but it will make sure that if we provide it in a separate rpm that it it is installed.

Thanks- works like a charm after you ran the yum install php-xmlrpc. I saw package headers while poking around, and just assumed it was installed already.[/QUOTE]

Presuming that you got this worked out, how is MB 5.1 working for you? I’d like to upgrade, but the initial work seems daunting, and MB 4.4 seems decent enough for now. Is it worth it, even though I end up transferring so much manually?

Many Many clients have chosen to stick with MB 4.4, largely because all mods are not yet available for 5.x and many dislike the interface. MB knows this and is supporting both for now.

I’m not doing anything extreme (really underutilizing it right now), but I’d like to make better use of it. InterWorx appears to have stuck with 4.4, but I wasn’t sure if this is because it’s due to the total amount of work required or something missing.

Actually I believe it is a heavily modified even older version. Chris or Greg would be the best people to ask.

We’ve stuck with 4.4 for a few reasons:

  1. We’ve written a ton of custom mods for 4.4 that we just don’t feel like converting at this time to 5.

  2. We really don’t use many of the v4 features let alone all they put in v5.

There’s really no need, at least for us, to upgrade. 4 works :slight_smile:


It’s not quite ready yet- 5.1.2 build 4 only worked with random password on provisioning (can’t let user select) and some events need to be run manually. And events are a mess- billed all my activive customers for every domain ever provisioned last week!

Build 6 won’t provision Interworx account at all- will be trying the 5.1.3 CVS this week.

Is it worth it? Well, playing around with it is helping me get up to speed, so it’s worth it for me- plus it doesn’t cost anything to try it- my v4 licence allows me to run v5 too.