Arbitrary subdomains


is it possible to set up Siteworx so that anything.mydomain.tld displays mydomain.tld? It should also work for anything.anything.mydomain.tld, anything.anything.anything.mydomain.tld etc.
And I really mean “anything.mydomain.tld”, not “somethinginparticular.mydomain.tld” that I would create in Siteworx. It needs to work for anything.

I have a website that creates sites for its registered users in the form of username.mydomain.tld ? this is handled by PHP on mydomain.tld. This is something that has always worked on my previous hosts and even on my current host before they switched to Siteworx. Since my site has hundreds of users, creating each subdomain manually in Siteworx is out of the question.
Since I need this functionality for my website, if this isn’t possible with Siteworx, I would have to switch hosts. I would prefer not to switch hosts, and I’m sure Siteworx would also prefer people keep using their system.

Thank you


If I understand your what your asking correctly, your looking for a wildcard dns entry, which should work without issue but I’m not too sure of your issue fully.

This though should be set at where the dns is actually in control of the domain.

Usually to set wildcard you set it as *.domain.tld and simply point it to the correct ip.

As an example, if you had wildcard set you could use anything.domain.tld or myanything.domain.tld etc…

Please note though we don’t usually use wildcard and I’ve not tested the wildcard function in interworx dns but we do have times when we need to set it up for clients.

That said, if your only referring to siteworx, are you an end user

I hope that helps

Many thanks


Hello John,

Thanks for your reply. I actually do have a wildcard set up. It’s CNAME *.mydomain.tld pointing to mydomain.tld. Unfortunately, when I go to anything.mydomain.tld with this set up, it shows a testing page that goes like this:

This page is used to test the proper operation of the new SiteWorx account setup for someotherdomain.tld. If you see this page then it works!

yadda yadda

This, of course, is not what I want. I want it to point to mydomain.tld.
And yes, it does actually seem to be for a completely different domain than the one I own. This is on a web host that has recently switched to Siteworx as their control panel/management system/god knows what Siteworx actually is and how it works. I do have access to the Interworx control panel, where I can create and manage hosting for domains and all that jazz. Before my host switched to Siteworx, this DNS setup worked flawlessly.

Would an A record pointing to the IP instead of a CNAME record make any difference? I would think not. Perhaps something to be configured in the Siteworx control panel? Or something specific I should tell my host to do?


Many thanks and I’ve just tested on our systems and concur it does the same as you’ve reported.

I suspect the server needs restarting after updates which I’ll try later today out of hours and let you know. If it is, all you would need to do is ask your provider to restart their systems, if not, to help you I’ll open a tick with interworx.

To answer your other queries, the domain it is showing is the first domain in the list, which may not be any if your domains as your a reseller I think.

Siteworx is the control panel for users whilst nodeworx is the administrator control panel or reseller control panel.

We have been using interworx for just over a year and I can let you know we’re very impressed with it and we will be looking to increase our systems, and test clustering.

Many thanks



I’m sorry I wason the track of thought and you do not set the wildcard in DNS section at all, it is self created for you and links to vhost file.

Here is the link on the forum which shows you how to set a wildcard for a domain, and I’ve tested it on our system and it works lovely.

First though, please delete your current wildcard from DNS, then do the following:

make sure your logged into the siteworx account for the domain
goto hosting features, domains, subdomain
in the subdomain new box, just type a *
then click add

you can then check from the DNS that a cname has been created, and then you can check using anything.domain.tld

I hope this resolves your issue

Many thanks


Thanks a lot, John! I did actually try this before, but for some reason it didn’t work, whereas it works now . I’m not sure why that is, but hey, it works!
Thanks again!