Awstats dnslookup settings

I have a couple of issues for which I’d appreciate some help.

I have a number of large webserver log files (100’s of MBytes) to be analysed each day. Current stats processing is taking about 3 hours. That’s not a major problem in itself, however, while the daily stats job is running the server log files ‘disappear’ - that is there is no file transfer.log in my …/var/domain/logs/ directory. The transfer.log file reappears about 3 hours later (I’m assuming this is when the stats run finishes). When I look at the analyser results there is a consistent gap for the first 3 hours of each day corresponding to where the log file is missing

As a first attempt I’m trying to turn off the DNS lookup in AWSTATS to reduce the run time.
The config file at /etc/awstats.conf contains the directive DNSLookup=0.
However when the daily stats job runs, I still see the following process executing:
sh -c /usr/bin/ -dnslookup /home/sexybabe/var/*.log > /tmp/statsFJhWDO
and that step is taking the 3 hours or so to run.

I’m looking for some help to:

  1. continue to log activity even when the stats analyser is running - ie, rotate the log first then run stats on the rotated log
  2. turn the dnslookup off to reduce the run time

Many thanks,

We patched this issue in 4.9.