Awstats + httpd problem?

I have a very fresh installation of Redhat Enterprise 4.0 + Interworx-CP 1.9.1. Awstats has not worked from the beginning, while the other stats do. I got a bit curious, so I finally tried running the Awstats update script manually and got this:

# /usr/bin/ now -awstatsprog=/var/www/awstats/
Running '"/var/www/awstats/" -update -config=localhost.localdomain -configdir="/etc/awstats"' to update config localhost.localdomain
Update for config "/etc/awstats/awstats.localhost.localdomain.conf"
With data in log file "/var/log/httpd/access_log"...
Phase 1 : First bypass old records, searching new record...
Searching new records from beginning of log file...
AWStats did not find any valid log lines that match your LogFormat parameter, in the 50th first non commented lines read of your log.
Your log file /var/log/httpd/access_log must have a bad format or LogFormat parameter setup does not match this format.
Your AWStats LogFormat parameter is:
This means each line in your web server log file need to have "combined log format" like this: - - [10/Jan/2001:02:14:14 +0200] "GET / HTTP/1.1" 200 1234 "" "Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)"
And this is an example of records AWStats found in your log file (the record number 50 in your log): - - [13/Mar/2005:21:20:21 -0600] "GET /php_pb.png HTTP/1.1" 200 1132
Setup ('/etc/awstats/awstats.localhost.localdomain.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory).

So great, I see the problem. My localhost web server log is not using the preferred logging format, at least not what Awstats was configured for. However, considering this is a brand-new installation, wouldn’t this qualify as a bug?

Sorry, I intended to post this under “Nodeworx --> Bugs”. But maybe this isn’t a Nodeworx bug either. Could a moderator please move my thread to the appropriate forum?