Awstats not updating?

Currently trailing the panel and enjoying it so far. However, so far the only problem I’ve come across is that awstats isn’t updating.

[TABLE=“class: aws_data sortable, width: 100%”]
[TD=“class: aws”]Statistics for:[/TD]
[TD=“class: aws”]my.tld[/TD]
[TD=“align: center”][/TD]
[TD=“class: aws, width: 150”]Last Update:[/TD]
[TD=“class: aws”]Never updated (See ‘Build/Update’ on awstats_setup.html page)[/TD]
[TD=“class: aws”]Reported period:[/TD]
[TD=“class: aws”]Month Jan 2016[/TD]

Everything is at “0” and I cannot seem to locate any system menu or user menu to recalculate the stats.

I read a few posts that awstats is dead in IW but I hope not as I would like to migrate a couple of users that enjoy using awstats.
Anyone got any hints to get working?

OS: Centos 7
IW: v5.1.3
Fresh Install - 1user account.


Edit: I’ve tried creating a new reseller account and new account for a second domain, and it’s not even creating weblizer/awstats stats.

Hi David

Welcome to IW forum

How long have you had a website running and are there any calls to the website

I know our awstats shows details, but I think stats run every 24 hours, but I could be wrong sorry.

Also, I thought a 1 user license was for only 1 account, so did you see any warnings or failures when creating a second user account, and I believe from licensecart that the 1 user license was for DNS servers

Many thanks


Thanks d2d4j,

I’m currently evaluating the trial unlimited license with clustering. If the stats run every 24 hours, then that sounds like a logical reason to why I’m not getting any figures. I’ve checked and Apache is logging correctly so I’ll give this a shot and see what happens.

I’ve used Plesk and cPanel but seriously enjoying my time with InterWorx and might be getting a little bit too excited. Shame the forum is a bit of a ghost town.

Thanks for the reply.


Did you enable Save Web Transfer Logs when SiteWorx account created?

Hi David

Apologies I am not sure why I thought you had a 1 user license as I’ve just reread your post and there’s no mention of 1 user license. Must be old age or my eyesight deteriorating

Clustering works lovely, with many variants on how you can set services up.

Have you considered high availability clustering (HA), which works the same as clustering, but has controller failover to a secondary cluster node controller

Glad your enjoying it so far, I know we have a lot of ex cpanel clients, who think it’s lovely to use

Any user is free to post, as long as it conforms to the forum rules, and there are a lot of highly experienced users on this forum, but it would be nice if more users posted, particularly if they have created hooks, or themes etc

Many thanks


dss, I believe so. I can view all the entries manually within the SiteWorx just no listings for others.

d2d4j, Is HA available? I’ve been reading up on documentation and they mention it was an up-coming feature. However just discovered there was a Private Beta (which is closed) but seriously looking forward to this feature once it’s available.
I’ve not had the chance to setup clustering just yet but it’s something I plan to do over the next few days.

With regards to clustering, IIRC I read that you have to IW in an blank state. Is this true? Or can I setup clustering with clients already on the system?

Hi David and dss

Good point dss

I was part of the HA clustering beta, and I can definitely say it was lovely. We even did a few hard fails on cluster manager ie we just pulled the power lead out and it worked like a dream.

I believe though, it used only centos 6 but not heard anything since

I believe for clustering, you need to set your /home to /chroot/home and I believe it’s possible to change to /home to /chroot/home with siteworx accounts setup, but is a little involved, so if you have only a small number of siteworx accounts, it might be better to do a blank IW and then import them onto cluster.

I hope that helps a little

Many thanks


Damn, that sounds good. Look forward to it.
Well weblizer has updated itself for the second domain which is good, still nothing on awstats though. So yeah, I think you might be right it’s a 24hr thing.

I don’t mind involved stuff, it’s what I do for a living anyway but thanks! helped a lot :slight_smile:
It’s just more of the thought of that if I need to scale in the future (which I hope I will) if it’s possible just to setup cluster.


Hi David

Sounds good, hope it goes well for you

Sorry, just so it’s clear, the cluster uses only 1 /chroot/home and is usually on the CM. However, you could separate out the /chroot/home onto its own server, as long as the CM and nodes can see it

Then adding another node at anytime is exceptionally easy and quick, as is bringing a node offline

If you need the instructions for moving /home just pm me and I’ll look them up, as I’ve done it before but a while ago, and my memory is not what it once was sorry, so may take me a little time to find it

Many thanks


Thanks d2d4j

awstats is reporting “0” for both tld’s.
Analog also appears to be broken. Whats the next steps for getting this working?

Hi David

Oh dear

Are there any cron job errors shown in nodeworx, server settings, logs, interworx, cron I think from memory

I believe it runs around midnight

I’m just onsite at a clients st the moment, but will check when I’m back

If it’s urgent, you can open a support ticket with IW support

Lastly, what is your distro

Many thanks


Thanks, no rush, although I may open a support ticket in-case this is a one of the kind bug. pretty normal occurrence with me.

OS: CentOS Linux release 7.2.1511 (Core)
The only error’s I’m seeing which is from “error.log” within NodeWorx is this:

[Fri Jan 22 11:42:13 2016] [error] [client ] : No such file or directory, referer:
[Fri Jan 22 11:42:13 2016] [error] [client ] /bin/grep: /home/interworx/etc/logs.d/nodeworx/*.yaml, referer:
[Fri Jan 22 11:42:12 2016] [info] Initial (No.1) HTTPS request received for child 0 (server
[Fri Jan 22 11:42:12 2016] [info] Seeding PRNG with 144 bytes of entropy
[Fri Jan 22 11:42:12 2016] [info] [client ] Connection to child 0 established (server
[Fri Jan 22 11:42:11 2016] [info] [client ] Connection closed to child 1 with standard shutdown (server
[Fri Jan 22 11:42:11 2016] [info] [client ] (70007)The timeout specified has expired: SSL input filter read failed.
[Fri Jan 22 11:42:08 2016] [error] [client ] /bin/grep: /home/interworx/etc/logs.d/nodeworx/*.yaml: No such file or directory, referer:
[Fri Jan 22 11:42:07 2016] [info] Subsequent (No.2) HTTPS request received for child 1 (server
[Fri Jan 22 11:42:04 2016] [error] [client ] : No such file or directory, referer:
[Fri Jan 22 11:42:04 2016] [error] [client ] /bin/grep: /home/interworx/etc/logs.d/nodeworx/*.yaml, referer:
[Fri Jan 22 11:42:04 2016] [info] Initial (No.1) HTTPS request received for child 1 (server
[Fri Jan 22 11:42:04 2016] [info] Seeding PRNG with 144 bytes of entropy

2016-01-20 13:21:07.37201 [_daily-zhe0-sq03-PHP] [INFO]  : failsafe restarting httpd : stats.php 
2016-01-20 13:21:11.63691 [_daily-zhe0-wnl2-CLI] [INFO]  : processing domain: : stats.php 
2016-01-20 13:21:11.64464 [_daily-zhe0-wnl2-CLI] [INFO]  : looking for logs like: /home/cyberp/var/*.log-processing : stats.php 
2016-01-20 13:21:16.95225 [_daily-zhe0-wnl2-CLI] [INFO]  : running webalizer : stats.php 
2016-01-20 13:21:17.12039 [_daily-zhe0-wnl2-CLI] [INFO]  : running analog : stats.php 
2016-01-20 13:21:17.38295 [_daily-zhe0-wnl2-CLI] [INFO]  : running awstats : stats.php 
2016-01-20 13:21:27.27183 [_daily-zhe0-wnl2-CLI] [INFO]  : all stats programs complete : stats.php 
2016-01-20 13:21:27.27243 [_daily-zhe0-wnl2-CLI] [INFO]  : total transfer.log logs found:  0 : stats.php 
2016-01-20 13:21:27.27255 [_daily-zhe0-wnl2-CLI] [INFO]  : total transfer.log logs wanted: 7 : stats.php 
2016-01-20 13:21:27.27271 [_daily-zhe0-wnl2-CLI] [INFO]  : total error.log logs found:  0 : stats.php 
2016-01-20 13:21:27.27282 [_daily-zhe0-wnl2-CLI] [INFO]  : total error.log logs wanted: 7 : stats.php 
2016-01-20 13:21:27.31551 [_daily-zhe0-wnl2-CLI] [INFO]  : logfile_match is: /home/cyberp/var/*.log-processing : stats.php 
2016-01-20 13:21:27.31576 [_daily-zhe0-wnl2-CLI] [INFO]  : trying to delete: /home/cyberp/var/*.log-processing : stats.php 
2016-01-20 13:21:27.36023 [_daily-zhe0-wnl2-CLI] [INFO]  : done deleting logs : stats.php 
2016-01-20 13:21:27.38807 [_daily-zhe0-hc9h-PHP] [INFO]  :  routing: Ctrl_Nodeworx_Http -> restartCommit : stats.php 
2016-01-20 13:21:27.67045 [_daily-zhe0-hc9h-PHP] [INFO]  : failsafe restarting httpd : stats.php 
2016-01-20 13:21:31.91497 [_daily-zhe0-wnl2-CLI] [INFO]  : script end : stats.php 

2016-01-21 18:21:07.19014 [_daily-8j0e-xf1f-CLI] [INFO]  : script begin : stats.php 
2016-01-21 18:21:07.19028 [_daily-8j0e-xf1f-CLI] [NOTICE]: stats.php --chunksize=200 --chunk=1 : stats.php 
2016-01-21 18:21:07.40065 [_daily-8j0e-6s8j-PHP] [INFO]  :  routing: Ctrl_Nodeworx_Http -> restartCommit : stats.php 
2016-01-21 18:21:07.70407 [_daily-8j0e-6s8j-PHP] [INFO]  : failsafe restarting httpd : stats.php 
2016-01-21 18:21:11.98630 [_daily-8j0e-xf1f-CLI] [INFO]  : processing domain: : stats.php 
2016-01-21 18:21:11.99543 [_daily-8j0e-xf1f-CLI] [INFO]  : looking for logs like: /home/cyberp/var/*.log-processing : stats.php 
2016-01-21 18:21:19.24461 [_daily-8j0e-xf1f-CLI] [INFO]  : running webalizer : stats.php 
2016-01-21 18:21:19.45851 [_daily-8j0e-xf1f-CLI] [INFO]  : running analog : stats.php 
2016-01-21 18:21:19.69680 [_daily-8j0e-xf1f-CLI] [INFO]  : running awstats : stats.php 
2016-01-21 18:21:29.53914 [_daily-8j0e-xf1f-CLI] [INFO]  : all stats programs complete : stats.php 
2016-01-21 18:21:29.53979 [_daily-8j0e-xf1f-CLI] [INFO]  : [B]total transfer.log logs found:  0 : stats.php [/B]
2016-01-21 18:21:29.53991 [_daily-8j0e-xf1f-CLI] [INFO]  : [B]total transfer.log logs wanted: 7 : stats.php [/B]
2016-01-21 18:21:29.54006 [_daily-8j0e-xf1f-CLI] [INFO]  : [B]total error.log logs found:  0 : stats.php [/B]
2016-01-21 18:21:29.54017 [_daily-8j0e-xf1f-CLI] [INFO]  : [B]total error.log logs wanted: 7 : stats.php [/B]
2016-01-21 18:21:29.57774 [_daily-8j0e-xf1f-CLI] [INFO]  : logfile_match is: /home/cyberp/var/*.log-processing : stats.php 
2016-01-21 18:21:29.57791 [_daily-8j0e-xf1f-CLI] [INFO]  : trying to delete: /home/cyberp/var/*.log-processing : stats.php 
2016-01-21 18:21:29.61627 [_daily-8j0e-xf1f-CLI] [INFO]  : done deleting logs : stats.php 
2016-01-21 18:21:29.64273 [_daily-8j0e-xf1f-CLI] [INFO]  : processing domain: : stats.php 
2016-01-21 18:21:29.64844 [_daily-8j0e-xf1f-CLI] [INFO]  : looking for logs like: /home/yarozeuk/var/*.log-processing : stats.php 
2016-01-21 18:21:33.78055 [_daily-8j0e-xf1f-CLI] [INFO]  : running webalizer : stats.php 
2016-01-21 18:21:33.94812 [_daily-8j0e-xf1f-CLI] [INFO]  : running analog : stats.php 
2016-01-21 18:21:34.23205 [_daily-8j0e-xf1f-CLI] [INFO]  : running awstats : stats.php 
2016-01-21 18:21:44.11067 [_daily-8j0e-xf1f-CLI] [INFO]  : all stats programs complete : stats.php

Otherwise, no other errors that I can see.
all Cronjobs look like they executed correctly, but for some reason it’s not populating awstats

Although I’m concerned by seeing: “found 0 - wanted 7”

Hi David

The wanted 7 would be the retention days set in settings for the number of days for retention of logs.

Found 0 would indicate there are no logs

The quandary is webalyser found the logs to display, and that is shown first in line of your posted errors for collection of logs, and awstats and analog show blank

I would have thought permissions if it were not for webalyser

I would open a support ticket and let IW support have a look, as you may have found an issue.

If you could confirm by looking at the log directory and seeing if there are any logs present, that would be handy to know

I’ll have a little think more this afternoon but if you open a support ticket, please ensure you state you have activated remote connection, otherwise it maybe delayed as IW will not know, and if you could update thread, I’d appreciate it

Many thanks


I’ve raised a ticket :slight_smile: will update once I hear back.

The files are populated too.
I guess if the worse comes to worse is that I reinstall and set-up the host on CentOS 6 and test.

Thank you for your help

Got a reply, apparently it’s a bug within CentOS7. It’s in the dev queue. Unsure of an ETA though.

That solves that. Time to reformat and throw on CentOS6.

Hi David

Many thanks for your update, much appreciated

Please remember to set to /chroot/home if reformatting

Hopefully the issue will be resolved quickly on centos 7, and sorry, that’s the first I had heard of this issue

Centos 6 works lovely

Many thanks