Binding IP Aliases: Failed

I’m missing something, and it must be easy …

Clean CentOS 4.2 system. New Iworx install.

I’m setting up a test box internal to my network on a private IP (static), all seemingly goes well with the process with the exception of : Binding IP Aliases: Failed.

I figure that since I don’t have any (only one IP assigned), maybe that’s the problem. So I create a range0 file and add a few. Reboot. Same error. I’ve tried re-running the install script after adding the range, ditto-licious.

The box is pingable, and the default IWorx Apache page answers either by internal DNS name or IP - but the /nodeworx site returns a blank page. If I try to run the goiworx.pex (thinking maybe it needs the license file first), it returns the “The IP address (x.x.x.x) of the server was not set!” error.

… the problem must be right in front of me and I’m just not seeing it.

You’ll get the Binding IP Aliases: Failed message until the goiworx script has completed successfully.

You’ll get the “IP address (x.x.x.x) of the server was not set!” message as long as a 10. or 192.168 internal IP is on eth0. You can choose to activate the license on the internal IP if this is really what you want to do - the message is just meant as a reminder to bind the “Real” IP to the server, if that’s what is supposed to happen.


Gotcha. Good to know it’s functioning as intended.

I’ve got no issue putting a public IP on the box – I just wasn’t anticipating the script results using a private one.

(As a side note: if one wanted to create an internal web server only for in-house use – I assume a private IP (or nine) would be fine to use and ignore the script errors?)

Yes, that would be fine.