bug on 4.9.0 build 427, can't edit siteworx accounts without specifying new password

Apparently there is a bug on 4.9.0 build 427… it’s not possible to edit siteworx accounts without specifying a new password… i.e. leaving password field blank (if we don’t want to change it) it’s not possible to apply other changes… alert icon shows next to password input with alt “Usernames and email addresses cannot be used as passwords.”

Hi Nars,

Confirmed the bug, it looks like it only happens if the Nickname box is empty, can you confirm that’s what you see as well?



Hi Paul, Yes, I can confirm it, with a nickname no problem, only without it.

Btw, can you tell me why there is an option on cp to disable OS auto-updates, and not to disable iworx updates? It shows just Enabled as plain text, no option… I would really prefer to disable auto-updates and manually apply updates.

Thanks for reporting this nars - I was going to open a TT on mon about the exact same issue. Wasn’t aware it’s a regression.

Dumb question time - what’s the point of a nickname?

> Dumb question time - what’s the point of a nickname?

It can be used for the client’s full name, or any other identifying name you want to associate with the account - and it shows up in the account listing.

Paul: re my question above, disabling iworx auto-updates… today I decided to look at iworx.ini and found:


I guess autoiworx may be what I want? Can I just change it to 0 and periodically just run yum manually to updateboth OS and iworx? I know you may not recommend it… but I would really preffer to manually apply them when I’m around, should something go less good :slight_smile:

a bit off-topic: noticed that last update few days ago did undo my changes on /usr/local/interworx/etc/vhost-base.conf and /usr/local/interworx/etc/webalizer.conf, I think I can actually set another path for vhost-base.conf on iworx.ini to avoid this? any chance you could please also add an ini entry allowing to set path for custom webalizer.conf?