Can't get from 3.02 to 3.03

I tried yum update to get up to 3.03 but it’s not working out. The only error before yum stops is:

Error: Missing Dependency: SpamAssassin >= 3.0.2 is needed by package interworx
Error: Missing Dependency: SpamAssassin is needed by package simscan

Both errors are peculiar because all the parts mentioned (sa, simscan, iworx) are all part of the same package. So I tried this with no luck:

rpm -Uvh --force

RPM errors included dependencies about iworx and siteworx 3.02 which is installed.

What can I try next?

Also, in Nodeworx under Server/Software Updates, auto updates is normally disabled. Shouldn’t there be a list of pending updates to install manually? Refreshing doesn’t list anything new and I’ve never seen anything listed here.

edit: The answer is documented here
In a single command the 3 rpms installed fine:

rpm -Uvh --force

and clamav is updated.

Hi sysnop,

The SpamAssassin dependency issue may be related to what spamassassin rpm is installed on your system. What does this return?

rpm -qi spamassassin


Everything came from iWorx rpms and the CP says 3.03 so I think I’m good to go.

[quote=IWorx-Paul;14570]What does this return?
rpm -qi spamassassin[/quote]
Name : spamassassin Relocations: (not relocatable)
Version : 3.1.9 Vendor: NEXCESS.NET L.L.C
Release : 100.rhe4x.iworx Build Date: Mon Jun 18 04:10:36 2007
Install Date: Fri Jun 29 12:04:00 2007 Build Host:
Group : Applications/Mail Source RPM: spamassassin-3.1.9-100.rhe4x.iworx.src.rpm
Size : 2896888 License: Artistic
Signature : DSA/SHA1, Mon Jun 18 04:13:05 2007, Key ID 625a2cc12652845d
Packager : Chris Wells <>
Summary : a spam filter for which can be invoked by mail delivery agents
Description :