CentOS 7 Install / Activation

Hello all,

I’ve been an interworx user for over 10 years and used to have an account on this forum but it appears it has been deleted because I haven’t visited in a while… so I had to remake my account. I see some of the same folks on here so that’s neat. :slight_smile:

Anyhow, I’m seeing an error that I’m hoping someone on here can help me troubleshoot. Due to a hard drive failure, today I’ve been working on setting up setting a fresh install of interworx up on CentOS 7. The datacenter also assigned a new IP to my server.

The iworx install completed on my server, and I entered my license key using the web interface. After I entered the information I received the following error:

A system error has occurred. Please try your request again in a few minutes.
If the problem persists, please contact Support.

To troubleshoot, so far I have:

  1. Changed my IP to the new IP in ModernBill.
  2. Checked to ensure the system time is in sync with iworx.
  3. Tried to execute “goiworx.pex” through SSH. [SIZE=2]However I also get an error:[/SIZE]
    “[ERROR] InterWorx has already been activated on this box. Quitting…
    [ERROR] Activation Failed”


Hi hexadecimal

Welcome back to IW forums, what was your previous forum user name if you don’t mind me asking

I am thinking the issue is as stated (sorry could be wrong, just going on a gut feeling)

Can you confirm port 2443 is open on incoming/outgoing firewalls etc

Have you confirmed the IP address your using matches on modernbill to your server (if you have more then 1 IP address it maybe trying to register on a different IP address - although I might expect this to state in error message)

You confirmed time sync but best to check

What shows if you run from ssh

/home/interworx/cron/license.pex --sync

Have you tried from ssh

~iworx/bin/goiworx.pex --key=LICENSE KEY --email=EMAIL ADDRESS --password=PASSWORD --ignorechecks

Obviously change license key email address and password to your information

If that fails as above, I might suggest you open a support ticket

I hope that helps a little

Many thanks


My previous username was actually the same as my current one, Hexadecimal. :slight_smile: I only had a handful of posts, so you probably don’t remember me. But I definitely remember your avatar haha.

Thanks for your troubleshooting tips! Turns out this issue was actually caused by my datacenter. There was an IP conflict on their end that was causing intermittent DNS issues during the IW install. As a result, the IW database wasn’t set up correctly. Thankfully Nathan was able to identify that and get it sorted for me. +1 for IW support. +10,000 for the IW panel. Wouldn’t use any other control panel!!

Hi hexadecimal

Glad you like my avatar, IW-Trevor made it for me

Glad it was resolved, IW Rock

Many thanks