Control Panel Reinstallation failed. Database setup failed

I have tried to reinstall the Interworx Control Panel, once via a browser and once by command line, each time after formatting drives and reinstalling Centos 7.9 OS 64 bit, and then running

sh <((curl -sL /interworx/7/install.sh)) -m 10.4

above is incomplete as I saw a message saying I can’t include links in posts,

and then

yum update

and I see this -

[WARNING] Problem setting up DB info. Trying again…
210927 12:52:30 [Note] /home/interworx/mysql/sbin/mysqld (mysqld 5.5.45-37.4) starting as process 31713 …
210927 12:52:32 [Note] /home/interworx/mysql/sbin/mysqld (mysqld 5.5.45-37.4) starting as process 31720 …
±---------------------------------------------------------------------+
| Setting up initial InterWorx Databases… |
±---------------------------------------------------------------------+

[WARNING] Looks like iworx was setup before on this box…

[ERROR] Database setup failed. Please contact InterWorx Support.
[ERROR] Activation Failed

But then when I try to contact InterWorx Support the page says I need to use the Forgot Password when its my first time to login to the new support system, which does not work.
I never receive an email even though I do receive emails to the same address for Interworx
invoices and forum emails.

Please advise.

Hi Saturn

Welcome to IW forums

I am not sure which email address is used from IW support, but you could always just email support(at)interworx.com and I thought the support password was the same as normal login, but sorry if I am wrong

You said you reformatted your drives, was this full format

Your install command did not look correct, so I have correct line that I believe should work, but if fails, change -m 10.4 to -m 10.3 or try without using -m 10.x

sh <((curl -sL /interworx/7/install.sh)) -m 10.4

should be

sh <((curl -sL https://updates.interworx.com/interworx/7/install.sh)) -m 10.4

Also, please make sure the Mysql is not moved prior to install. IW needs the default location for Mysql to install and once installed, you can move if you want/need too (this may have changed though sorry but I believe not)

Please remember, IW are in USA and so are a fews Hours behind UK time, approx 5 - 6 Hours UK time, so please do not expect an immediate answer but they do respond very quickly

If you could update your post with how you get on

Many thanks

John

Yeah, this is on us. The installer was updated to support 10.4 (and 10.5), but it looks like that changed script wasn’t copied to the place where the installer script is pulling from. So the script you get while running the curl command doesn’t actually setup MariaDB 10.4 properly. I’ve shared the updated script with @saturn via a support ticket and we’re working to get that updated in the repo the installer pulls from.

MariaDB 10.4+ isn’t configured out of the box to use passwords in the way previous versions did. The steps that were added to the installer allow for that configuration to occur. Since InterWorx can’t access MariaDB 10.4 the way it would have without those steps occurring, you’re running into these issues. The “Looks like iworx was setup before on this box…” message is probably more accurately an “we can’t access the database server in the way we expect and we assume that’s because someone has already setup InterWorx on this system since we strongly suggest it be installed on a fresh install”, but obviously, that’s a bit wordy.

The “register” button is hidden in the paragraph text next to the login form. It can be found here: Login - Interworx Support

UPDATE:

The installer scripts have been updated in the repos. I just ran a test install with MariaDB 10.4 on both IW6 and IW7 and both worked, as expected.

If you’re still having an issue, please let us know in your open ticket.

Thanks!

Hi

Kudos to @iworx-brandon

Good clear explanation of issue and extremely quick fix

Have you checked the php option works and for php 8 in installer

How fast things progress - or I’m getting very old as this was something we had to update manually after initial install/setup

Kudos to interworx

Many thanks

John

PHP 7.4 and 8.0 were added to the installer in February of this year, just before the MariaDB versions were added. I just completed a test install without issues using PHP 8.0. The installer script that was being pulled was from September of 2020, long before the changes to PHP and MariaDB were added, so it’s likely that both the PHP and MariaDB options were stuck in the same “updated, but not available” position.

Now that the installer is updated, you should be able to install with PHP 7.4/8.0 as the system version.

1 Like

Hi John and Brandon,

Thanks for your help, and thanks Brandon for your very fast support.
The updated script worked perfectly, with Mariadb 10.4 installed.