Cpanel Import Problems... 4 days running Invalid Interworx-CP license

I have tried every way interworx provides for importing from a cpanel, direct file (gui and cli), and ssh and I keep getting a license error. I have tried to import another account and it works, but this account just dies.

Here’s what the cli reports:

~iworx/bin/import.pex --archive=/tmp/backup-9.15.2014_16-37-49_[sitename].tar.gz --control-panel=cpanel --ipv4 [IP Address] --db-server=localhost --reseller-id=3 --force
Found --ipv4
[this matches IP address above]
A system error has occurred. Please try your request again in a few minutes.
If the error persists, please contact support.
[root@centos6 /]#

Here’s what ssh gui reports:

and finally here’s what gui (from file) reports (at the end)

? Quota Sanity Checking
? Loaded package option : Secondary Domains => 4
? Increased slave domains quota : 0 => 4
? Setting Reseller ID : 1
? Invalid InterWorx-CP License

Hi mikei

I hope you don’t mind but please could I ask if the cpanel account been imported has secondary domains, and or pointer domains.

Also, is the ipv4 address on your system set as shared and not dedicated, and if the cpanel account was shared or dedicated been imported.

I think you may have come accross the bug which is present when importing, and if so, if the cpanel account been imported has secondary or pointer domains set, you may need to remove these first before been able to import correctly.

I could be wrong though, and I know IW were aware, but not too sure if fix is released from beta yet, so you may want to open a support ticket and let IW have a look

Many thanks



Your response time is simply amazing. Thank you.

This cpanel has subdomains and I can’t remove them as they are live (very active) sites.

I am using a shared IP, that’s easy if that fixes the bug - I’ll just get another IP.

I did open a ticket with IW, and I believe my license reseller also opened a ticket. Frankly so far your support has been better than IW’s I simply got a response of “Weird. Can I have the necessary details to attempt to duplicate the failure, here?” and then the ticket went dark after I enabled remote support.

Meanwhile I’ve been trying every way to get this to work, unfortunately moving around 4.5gb files takes time and I’m losing my patience with IW products at the same time.

Hi Mikei

Many thanks, and please do not lose patience with IW, it is too good a product, and we have many clients who are ex Cpanel, they simply love IW.

Although I do not work for IW, I love them to bits, those guys rock and to be honest, if IW are getting involved on a licence reseller from your request, this is above the call of duty as the agreements states the licence reseller is the one to sort out issues, and if needed, they open a ticket with IW not the client.

It will get resolved, of that I am sure, and could be many things, including the version of Cpanel your using, if it is old, you may want to update it before importing, as this has caused failures in the past.

If your current IPV4 is set to shared, and the cpanel account is set as a shared IPV4, then it is not that sorry, it was just me thinking aloud.

I would ask your licence reseller for an update, and if they are asking for access, I would let them if it were me, or give them the backup, and let them figure it out, but I’m sure they will involve IW.

I hope that helps a little, and as I said, IW guys rock, they certainly know their stuff…

Many thanks


Hi mikei

I’m sorry, I just thought after rereading again and could I ask what licence type you have.

Is it a 35 site licence I think from memory, and if so, have you used all of them

I only ask because of the invalid licence

Many thanks


Hi Mike,

John is a rock star, no doubt :slight_smile:

Per the remote assistance thing you mentioned – we’re not notified when remote assistance is enabled, so after enabling, you’ll need to respond to the ticket letting us know.

I’m working on arranging an FTP server for you now. FWIW – the issue shouldn’t be related to subdomains, as your license is a VPS license, and subdomains are only limited for the 35-domain licenses.


Hi Brett

Excellent, you guys rock

Now that’s support for you😀

Many thanks


Closing out this thread.

I had a very large installation, 4.5gb of data. After several failed attempts my disk space was low causing these errors. Granted, it should not have thrown a “license error” but ultimately it was a disk space problem.

It was resolved quickly by IW team - thank goodness for the remote login capability in IW.

Hi mikei

Many thanks for posting what the issue was, which I have to say was not what I was thinking sorry.

IW guys rock and they are very experienced and knowledgable.

I hope your all good to go now

Many thanks