Creating accounts fails :: Cannot change Quota's or Permissions

When i attempt to create a new account regardless of what domain i enter or what details i fill in then i receive a message saying that account creation failed and that there is more info in the iworx.log file.

I have found the error messages from iworx.log (/usr/local/interworx/var/log/iworx.log) and they are listed below:

Mar 13 11:15:53 package.activate.php [debug] barfing: /home/domainne/.qmail
Mar 13 11:15:53 package.activate.php [info] setting permissions on: /home/domainne
Mar 13 11:15:54 package.activate.php [info] setting quotas for: domainne to 200 MB
Mar 13 11:15:54 package.activate.php [info] /usr/sbin/setquota -g domainne 184320 204800 0 0 /
Mar 13 11:15:54 package.activate.php [error] error changing quotas: domainne
Mar 13 11:15:54 package.activate.php [error] activating package: domainne: failed

I replaced the domain with “domainne” (just a random username), i have been unable to see why interworx cannot set quotsa or permissions on /home, it was working about 2 days ago but now i need to add a new account it just fails like this.

Has anyone else come across something like this? If anyone could help me it would be greatly appreciated



Try rebuilding your quotas. Run the following command as root:

quotacheck -cugvmf -F vfsv0 PARTITION

Where PARTITION is the partition that your /home dir is on. For example, if you have one large root directory where /home resides, you would run:

quotacheck -cugvmf -F vfsv0 /

If /home is it’s own partition, you would run:

quotacheck -cugvmf -F vfsv0 /home

Whatever PARTITION is, make sure it’s the same partition listed in the iworx.ini under:



Done, got the following messages:

quotacheck: Checked 9553 directories and 120173 files
quotacheck: Old file not found.
quotacheck: Old file not found.

Does this mean that it has error’d out?

Nope, those messages are normal. Can you create a new account now?

Is this a VPS?

Yeh it is a VPS, Actually had to run it twice and then it fixed my quota’s and account setup. Thank you.

Same problemٍ

I have the same problem : error when setting quotas…

but when I run the command :

quotacheck -cugvmf -F vfsv0 / it writes :

quotacheck: Mountpoint (or device) / not found.
quotacheck: Can’t find filesystem to check or filesystem not mounted with quota option.

Even if in iworx.ini I have in [quota] partion = “/”

I tried :

quotacheck -cugvmf -F vfsv0 /home
I can read :

quotacheck: Scanning /dev/sda4 [/home]

and at the :

quotacheck: Scanning /dev/sda4 [/home] done
quotacheck: Checked 4 directories and 9 files

(note that on the server I have only interworx installed nothing other)

I runned this command 2 and 3 and more times and it still doesn’t work…

please can u help me ??? it’s very urgent :frowning:
thank you very much…



I just responded to your support ticket that you opened. Please see my response there.



Hello, Perfect :slight_smile:

thank you very much. It’s working for the 2 servers (I did it for the second one)

ohhhh I know how much Socheat looooooooves VPS systems :wink:

SO what was done to fix this problem? I’m having the same issue:
-bash-3.2# quotacheck -cugvmf -F vfsv0 /
quotacheck: Mountpoint (or device) / not found.

etc/fstab doesn’t even exist.

Also a VPS. I just started using cloudmin and installed their base XEN Centos VPS on one of the servers to give it a whirl.

Problem solved for me. fstab does exist - it was vi that didn’t… one of those days…

Anyway, i added ,usrquota,grpquota to the /etc/fstab for the root partition and then it touched /root/aquota.user and then reboot.


Hi dennisdee

I think your mount is wrong.

If your not sure how to mount correctly, I would restart your vps or as root, I’d try mount -o remount /

Then you need to rebuild quotas quotacheck -cugvmf -F vfsv0 /

Many thanks