Deleting Secondary Accounts does not remove data

I noticed when deleting the accounts they are removed from SiteWorx Secondary List and the main (symbolic link based folders e.g. /home/account/mysecondarydomain.com/html) are removed.
But the actual data storage folders (e.g. /home/account/mainaccount.com/html/mysecondarydomain.com) still have all the data.

Seems like those are just kind of orphaned.

EDIT:
Looks like this has to do with cPanel imports and not really the secondary account setup in the main system
http://forums.interworx.com/forum/siteworx/bugs/44011-deleting-secondary-accounts-does-not-remove-data?p=44034#post44034

Hi Justin

I hope your well

I am sorry, I have read and reread to make sure I understood your post, but I am not able to reproduce this sorry.

I added a secondary domain, then checked it was created, deleted the secondary domain and rechecked (see pictures).

Also, rereading I thought ahhh symlinks, so I manually checked as below (note details have been changed)

I do not think there is any symlinks and the secondary domains are created in their own space, not shred with main domain. However, you could alter this so it is, but this is outside of IW. I seem to remember you posting over doing this a few years ago, but sorry if I am wrong, old age creeping up fast…

Many thanks

John

[[email protected]** ~]# cd /chadmin/home/!!!shc/
[[email protected]** !!!shc]# ls
!!!.co.uk public_html var
[[email protected]** !!!shc]# cd /chadmin/home/!!!shc/!!!.co.uk
[[email protected]** !!!.co.uk]# ls
html iworx-backup
[[email protected]** !!!.co.uk]# cd /chadmin/home/!!!shc/!!!.co.uk/html
[[email protected]** html]# ls
cgi-bin index.html robots.txt smf
[[email protected]** html]#

myurl-sec-files.png

myurl-sec-files-deleted.png

Based on the pictures this is how mine looks. The “myurl.co.uk” is removed from the top level /home/account/myurl.co.uk, but if you looked in that folder, it has an html inside of it which is just a symlink to /home/account/maindomain.com/html/myurl.co.uk. The data in this folder is not removed. Check on your machine now since you already deleted, this folder should still exist.

Hi Justin

Many thanks and sorry, I still am not fuly understanding the location

If you do not mind, I have PM you a login for a siteworx account and allowed SSH so you can check on our server

This is a new server, with latest IW and Centos 7, not currently in production but is nearly ready to be installed into datacentre to go live.

I think if I have understood correctly, you should not find any data left over, but sorry if I am wrong

Many thanks

John

Thanks for that, I’m seeing this as well on your test account. Then I went back to my server and tried and it’s the same, so I now realize the problem must be related to cPanel import.

When cPanel imports secondary domains (and subdomains) it imports them all as secondary domains in the SiteWorx account. The path it creates is the one I showed above, where the “/home/account/myurl.co.uk/html” is just a symbolic link. But in my test using SiteWorx to create the secondary domain instead of cPanel on both your server and mine, the html directory is a real directory. So when you delete the secondary account it totally removes it an all it’s data.

So the real problem here isn’t with secondary domains, it’s how the Importer works and doesn’t follow the same convention for secondary domains as the core system.

Hi Justin

Kudos to you

Good find but I?m not sure how best that maybe corrected.

If I remember correctly, the CPanel import worked that way because of the symlink in CPanel

I will forward your thread to IW and tag it to your CPanel failure issue raised as it maybe related perhaps. Sorry if I am wrong

Many thanks and have a lovely weekend

John