Disable Webmail

How can I disable webmail for accounts that don’t have local mail delivery?

Hi Johan_hammy

I do not think you can disable webmail login page but if the email account does not exist in the siteworx account, then they cannot login to it.

To disable local delivery for email, goto siteworx account, administration, email and disable local delivery

Once disabled, if any email accounts are setup, and you don’t want them to be used by webmail, delete or disable the account

I hope that helps and sorry if I have misunderstood your question

Many thanks


The first part seemed to get it. If no one can login due to the mail not being on that server, I’d like to not expose the webmail login form. Seems kind of pointless to expose something that can’t be used.

Hi johan_hammy

Yes, I understand but the webmail is a rewrite, so it works on all siteworx accounts

I suppose you could always add a specific rewrite for the siteworx account, but this could prove time consuming if there are a lot of them, unless your IW server never uses local mail, then you could remove the rewrite

Many thanks


Has anybody figured out a workaround on this issue?
We have a customer that wants us to disable the ‘domain.com/webmail’ page from showing on his account.
We tried to make a ‘webmail’ folder on his site but that does not work.
Any ideas will be greatly appreciated.
Thanks and Regards,

Hi crservers

If it’s just 1 or a few, I’m thinking you might be able to insert a domain specific rewrite rule above /webmail rewrite rule

I have not tried it myself, but think it may work

Many thanks


Hello John,
Thanks for your response.
Can you be more specific on how to accomplish this?
Where is the “/webmail rewrite rule” located?

Hi crservers
I believe it needs to go in iworx.conf, but could be wrong
ssh into server
vi /etc/httpd/conf.d/iworx.conf (or use any editor you prefer)
add under rewrite rule
RewriteRule yourdomain.url/webmail(/)?$ http://your desired domain [R,L]
Once done, you will need to restart iworx service iworx restart
It may or may not work, or you may need a condition statement (RewriteCond rule), but if it does not work, I’ll have a think and try myself when I have time over the next week
The rewrite rule though is in iworx.conf, but this may affect all users
Many thanks