DNS Hostmaster email address not correctly using proper domain name


I’m sorry to bother you all but on our system, the hostmaster email address is not been correctly changed to use the actual domain name when a new domain is added.

We use Version 4 (latest stable) on a centos 6.4 64 bit (all patches installed), and the first time I saw this happening, I restarted the server.

External testing of a new domain added shows the following for the newly added domain.

SOA record checkAll nameservers provided a SOA record for the zone. This is good because your nameservers should be configured in a master slave relationship, which allows uniform updates and agreement of resource record data. The SOA records provided are:

Primary nameserver: ns1.d2d-helweb.co.uk.
Hostmaster E-mail address: hostmaster@dns-template.com.
Serial #: 2013081909
Refresh: 7200
Retry: 300
Expire: 1209600
Minimum: 10800

Any suggestions would be appreciated and I was not too sure where to add this in the forum, it may be a bug, but it affects siteworx, and in part nodeworx as it’s dns.

Many thanks


Hi John -

Looking into this now - I’ll let you know if I can reproduce it, and what to do about it.


Hi tim

Many thanks and sorry I wasn’t sure if its a big or not and where in the forum to add.

If you need access to our server please let me know.

Many thanks


Hi John,

We tracked this one down. If you’d like me to patch your server(s) just open a ticket and we’ll take care of it. It’s going to be fixed as well in the official 5.0 release, which is so close at this point I don’t think we’ll be doing another 4.x release before it (which is why I mentioned the patch alternative).



Hi Paul

Many thanks for letting me know and a special thanks to you all for your help.

If the release is going to be weeks away, we can just wait I think, but if its going to months away then it might be better to do.

Also, that made me wonder how many other users are still on version 4 and should I be better upgrading to version 5 sooner then wait, in respect of been too far away from the newer version and also the centos updates keep rolling, so is it better to keep just a few steps behind rather then been on stable.

I’m sorry if I have not expressed my thoughts to well and hope you understand what I’m trying to say.

Many thanks


We use Version 5 .0.12 on a centos 6.4 64 bit and the issue is still exist.
Where can I change that hostmaster email address?
Anyone, suggestion/help??

I don’t vaste my time to open a support ticket, because they use to answer with question or google link.

Hi bblori

I hope you don’t mind and I’m sorry if you are still having the issue, the latest update fixed our issue lovely.

Please could I ask if you are meaning existent domains created already or new domains created after the update.

If domains created prior, these need to be changed manually as they are already existent.

Also, you may want to check the dns template, nodeworx, system settings, dns zones, dns template.

If the above is not the issue and it is not correctly creating the hostmaster address, I would most likely open a support ticket for faster resolution and I’m sure any questions asked are only to help interworx understand better the issue reported.

Many thanks


Hi Bblori

I hope you don’t mind, but I was thinking about what I said, and I thought it might be easier to show you our dns template which works lovely (please see pic). It can be sometimes hard to express, sorry, but does your match the same.

I also have retested our system and it still works lovely, but this is a standalone, and as yet, I need to build our test cluster, which thinking about, you may be on a cluster, and therefore I would not know if you still have same issue, but I’m thinking not, as dns creation has to be the same on standalone or cluster I would have thought.

I hope this helps you, if not, as I said earlier, I would raise a support ticket or if you prefer not too, you may have to wait until a more experienced user posts.

Many thanks


Here is my video http://www.youtube.com/watch?v=Cliu8doj35g&feature=youtu.be&fmd=22

no comment :frowning:

Hi Bblori

Thanks for the video, I’m sorry but my eyes are not as good as they were and the video was small size sorry.

However, I have I believe found some differences between our template, in that on my default template, the SOA starts as 1.{domain}, where your video shows it as {domain}. I’m very sorry if I have misread though, as I say, it was hard to actually see, even on full screen as it blurs sorry (see pic with arrows).

Also, I believe you have it set to gmail.com as in myhost@gmail.com and on mine it is {domain} hostmaster@{domain}

Lastly, and please forgive me if I am wrong, but at the end of your video, it shows the new domain with the correct domain listed I believe, myhost@mywebsite.net so I am slightly at a loss as to what your asking, sorry.

Are you asking how to set it to the same domain you chose all the time or are you asking if it should be set to the newly created domain.

I hope you don’t mind me asking, and I’ll look again at your video to make sure, and please forgive me, as I may not have used the actual domain or email address for SOA, I was doing it from memory sorry.

Many thanks


Hi John, me again digging up older replies from you. I hope you don’t mind, but can you tell me what the 1. is for?



Hi Michael

To be honest,I don’t know sorry.

My thinking is as it was introduced at the same time as IPV6, it is the entry for ipv6 SOA.

I also think it might be connected to the NS which can be setup for resellers and users, as each can set their own or change them. This also relates to the issue you posted on gabors post, which I’ve thought about and have an idea but it’s very late here sorry, so I’ll post tommorow afternoon.

I’m sorry if I’m wrong though

Many thanks