Does R1Soft create a full backup of my server that can be used as a failover solution

Hi guys!
I have a server with OVH and I am looking for a failover solution. First thing that I thought was to setup a similar server, install interworx under a new licence and ask OVH if their failover actually syncs those two servers. Since OVH support is dead I thought to try an alternative solution with R1Soft.

Ideally I want to use R1Soft to copy my server into a backup server, then when I get issues with my main server I will use that backup like an image to setup a new server, then I will switch all of my sites dns to the new server IP(I am using Cloudflare so that is fairly easy to do). Since I am fairly new to all this I want to know if this is possible.
If it is are there any details that I must look for?

Thanks in advance.

Hi onspot

Yes, R1soft could do this, but it would cost you 2 IW and 2 R1soft licenses I think - well 1 more IW license so you have both servers licensed

In essence, quickly thinking, if you have 2 IW servers running, each with R1soft license, you can manually restore siteworx accounts between the R1soft licenses, ie you can choose to restore to the secondary R1soft server and not the primary R1soft license.

Alternatively, you could just have the second server ready, with no IW installed, then if needs require, install IW server, relicense to new server for IW, install second R1soft and do a restore, which saves you monies as this process would not take long

I hope that helps and it was only a quick thought

Many thanks


Thanks a lot for your reply John. As I never used R1Soft I didnt know that I needed two licences for this job. I was actually thinking to do the following with 1 IW and R1Soft licence.

  • Use my 1 IW licence for the active main server.
  • Buy one R1Soft licence and a backup server where I am going to store those backups, this is a site I found that provides such a service:
  • Keep all accounts(sites) under my Cloudflare account.

When live server goes down I’ll do the following:

  • Setup a new server, this is actually a public cloud instance so I can easily create a new instance with the same configuration.
  • Use R1Soft service at and restore the bare metal backup to the new server.
  • Change all DNS A IP records for my sites through CF to point to the new server.

What I dont know is if I need a separate R1Soft licences in order to rerstore the backup to the new cloud instance or I can use the licence I used on the old one or maybe I dont need any licence for my server(old or new)

Of course I understand that I should change my new server configuration too because its going to use the old server ones(IPs and hostnames).

I wonder if this scenario is do-able.

Hi onspot

Many thanks, and sorry, I was thinking you were needing a secondary server duplicated every day

You can do exactly as you have posted, and it should work lovely, with downtime for restore subject to connection speeds of R1soft to server

This is actually how we plan our doomsday plan, and we know for us, it should take around 2 hours on 1 gb networks

Have you checked licensecart website though, as I think mike is offering R1soft, but not too sure if it’s up and running

Many thanks


Thanks John.
I’ve visited Licencecart site, tehy do offer :
Thing is that I don’t understand the difference between the VPS Agent and the Dedicated Server agent, also it doesn’t seem to offer a backup server as well like does.

In general it seems I dont fully understand how R1Soft works in terms of architecture. Should I have 1 server to run R1Soft manager, then my live server and my backup server where R1Soft stores all live server backups or just the primary and backup server will do?

Hi onspot

Many thanks, and sorry if I’m not clear sorry

You only need a server license if you plan on running your own dedicated R1soft server.

If so, you then need the agent license(s) for each server. Dedicated server agent license is for an actual server with no vps setup on it (I believe).

The vps agent license is for vps servers, which contain vps or is a vps server held on a server

I could be wrong on the above though, so apologies in advance

I think you would be better just with the R1soft agent from a provider who runs their own R1Soft servers, and you pay monthly for license and space (which is cheaper then setting up your own R1soft server and all the configs etc for MySQL integration etc). This is how we have ours setup, and IW integration is for the agent license, so it’s ready for activation using your provider credentials and R1soft server URL.

I hope that makes more sense or is easier to understand how R1Soft works.

Many thanks


Thanks for your replies John.
I have already setup a demo cloud instance that has the same hardware setup as my live server. In there I have restored all files from the live server R1soft backup(they call it recovery point).

While the files seem to be copied fine I dont know if this procedure actually copies all needed Interworx config files and if it does what is it for me to change having in mind that this is a new server instance with different IP and hostname from the old one.

Best choice was to use a bare metal backup restore but this means I must find a way to upload the iso file and boot it in recovery mode which I cant(or I dont know how to do that).

Hi Onspot
Many thanks, I was not sure myself over bare restore as we have never had to do it, and hopefully never have too (touch wood)
Please see the PDF, which shows how to install your own ISO into OVH, which appears straight forward to do. However, how it works I am not sure, I am thinking it will not replace our NIC setup, or you may lose connection.
You would I think I need to replace all IP address(s) used from old server to new, and to do this, you need to SSH into server once restored with bare metal, and run the following as root or su
~iworx/bin/sh migrate-ip.pex
This then asks for old IP address and then new IP address and changes all IP address
Then check your host file to make sure it is correct
I would restart server and check all is well
If not using bare metal, I would need to think a little, but quickly, I would restore interworx folder in full, restore interworx database, restore the qmail folders, all home folders and databases, run migrate-ip.pex etc as above, and restart server, then check
I hope that helps a little, and sorry if sounding a little unsure, it is not something I have had to do and hope I never do.
Many thanks

insert-ISO-OVH.pdf (162 KB)

Sorry, please remember you will need to re licence your new server with Interworx, so log into your interworx account and change your license IP address, then run license pex from server to update server license.

Many thanks


Thank you John for your replies. I hope this thread will help others too.
I have just finished restore the R1Soft backup using the file restore type(all files selected). I noticed that the symlink between /chroot/home and /home wasnt created so I did that myself using the following command:
mount --bind /chroot/home /home

Then I tried to run the migration script ~iworx/bin/sh migrate-ip.pex but I got the following warning:
-bash: /home/interworx/bin/sh: No such file or directory
so I run the script once more leaving the “sh” out and it worked. After entering my Old Server IP I received one more warning:

Uncaught IWorx_Exception_DbUtil: DB Error: connect failed [nativecode=Can’t connect to local MySQL server through socket ‘/usr/local/interworx/mysql/iworx-db.sock’ (111)] ** mysql://iworx:fjt8wn1lkj@unix(/usr/local/interworx/mysql/iworx-db .sock)/iworx
A system error has occurred. Please try your request again in a few minutes.
If the error persists, please contact support.

So at first I tried to start mysql without success, this is the warning I got:

Job for mariadb.service failed because the control process exited with error cod e. See “systemctl status mariadb.service” and “journalctl -xe” for details.

As suggested I run systemctl status mariadb.service and I got the following:

mariadb.service - MariaDB database server
Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled)
Active: failed (Result: exit-code) since Sun 2016-02-14 19:31:05 UTC; 13s ago
Process: 1414 ExecStartPost=/usr/libexec/mariadb-wait-ready $MAINPID (code=exited, status=1/FAILURE)
Process: 1413 ExecStart=/usr/bin/mysqld_safe --basedir=/usr (code=exited, status=0/SUCCESS)
Process: 1383 ExecStartPre=/usr/libexec/mariadb-prepare-db-dir %n (code=exited, status=0/SUCCESS)
Main PID: 1413 (code=exited, status=0/SUCCESS)

Feb 14 19:31:03 server-3 mysqld_safe[1413]: /usr/bin/mysqld_safe: line 388: /dev/null: Permission denied
Feb 14 19:31:03 server-3 mysqld_safe[1413]: /usr/bin/mysqld_safe: line 569: /dev/null: Permission denied
Feb 14 19:31:03 server-3 mysqld_safe[1413]: 160214 19:31:03 mysqld_safe Logging to ‘/var/log/maria…rr’.
Feb 14 19:31:03 server-3 mysqld_safe[1413]: /usr/bin/mysqld_safe: line 708: /dev/null: Permission denied
Feb 14 19:31:03 server-3 mysqld_safe[1413]: /usr/bin/mysqld_safe: line 739: /dev/null: Permission denied
Feb 14 19:31:03 server-3 mysqld_safe[1413]: 160214 19:31:03 mysqld_safe Starting mysqld daemon wit…ysql
Feb 14 19:31:04 server-3 mysqld_safe[1413]: 160214 19:31:04 mysqld_safe mysqld from pid file /var/…nded
Feb 14 19:31:05 server-3 systemd[1]: mariadb.service: control process exited, code=exited status=1
Feb 14 19:31:05 server-3 systemd[1]: Failed to start MariaDB database server.
Feb 14 19:31:05 server-3 systemd[1]: Unit mariadb.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.

and this is where I am stuck now.

Hi onspot

Many thanks, your on centos 7 I think

I believe the issue is because you have mounted chroot/home

What does your fstab show (this is where chroot needs to show and IW symlink home)

I think once chroot is correct, and you restart server or iworx, then it should work, but please be aware if /home exists, you cannot just change /home to /chroot/home in fstab, as /home would have your home folders/files already now populated, and I would need to look up the full detail to change in fstab in this state.

It maybe quicker to reload vps and change /home to /chroot/home in fstab first, before restoring

I hope that’s alright

Many thanks


Hi onspot

Sorry, I was thinking about this today, and may have not fully taken in your last post.

If you uploaded the files after downloading to your computer, then symlinks and attributes would not be set, so I think the error is the error shown - permission issue

Can you double check between both servers and match your permissions/attributes to the backup server

Also, the chroot should be listed in fstab, but the symlink may have been not set as above

I believe r1soft set these only if restoring to an agent

Many thanks


Hello d2d4j, this didnt work after all. What I need is a way to use the server to server setup along with the ip failover.

Hey onspot,

I had the same challenge, I currently have a VPS storage server currently doing backups to R1soft 1 Archive a month and 29 incremental backups.

I don’t really trust R1soft for backup (had issues in the past with it) also I keep a backup to S3 using Duplicity for Databases and all files in /chroot* /etc* and some /var* (excluding var/lib/mysql - otherwise it will break the database)

As for your other issue, if you have a mounted secondary disk there is some issues with backing that up with R1soft (some permission related issues)
> check your fstab (my entry is /dev/xvdb1 /chroot ext4 defaults 1)
> check that your mtab entry is like (/dev/xvdb1 /chroot ext4 rw 0 0)
> if you do a whereis fstab - make sure the first entry points to /etc/fstab or where you want your fstab is located
> do the same for mtab

Hope that helps :smiley:


I think I’m getting slightly confused sorry

Onspot, the only way to a IW to IW import is if the original IW server was up and running. If IW to IW import is completed, the IP address should be correct to new IW server (our last mass import set the IP correctly)

R1soft, I have now had to import to a different IW server, and in order to do this, the r1sift on the new IW server, needs to be set in recovery mode, which then allows the transfer from 1 r1soft backup to another server

Inodecloud post looks good, belts and braces almost, but still would require manual actions to bring live

If your wanting high availability, you may want to look at setting up more vps with your provider, and then asking IW about high availability clustering, but you would need a minimum of 4 servers to do this, 2 cluster manager, 1 MySQL and 1 /chroot/home server. However, I am not sure if high availability works purely with vps

Many thanks