eGroupWare & 3.0 RC3

I have installed the eGroupWare ScriptWorx module on 3.0 RC3. It seems to install OK, but does not function.The first login attempt fails because the memory limit is too low.

PHP Fatal error:  Allowed memory size of 8388608 bytes exhausted (tried to allocate 7680 bytes) in /chroot/home/myictech/ on line 331, referer:

So, I bumped that to 16M and restart apache. Still no go.

PHP Fatal error:  Allowed memory size of 16777216 bytes exhausted (tried to allocate 23040 bytes) in /chroot/home/myictech/ on line 426

OK, bumped it to 24M. So far so good on that front, but the eGW IMAP client fails.

The connection to the IMAP Server failed!!*
This PHP has no IMAP support compiled in!!*

Sure enough, a check of phpinfo() shows no sign of IMAP support. While the config options show ‘–with-imap=shared’, IMAP support does not seem to actually be enabled because there is no IMAP info table in the phpinfo() output. The installed php is:

php.x86_64                               4.3.11-100.rhe4x.iworx installed

There are also a slew of other errors in the error.log related to missing files and undefined functions. This is the first ScriptWorx module I have tried. Not a very promising start…:frowning:

yum install php-imap

Then restart Apache.