Email addresses fails to get added to email clients

Hello there, running a brand new installation on a VPS. Had few domains added, SSL and some email addresses. DNS and SSL are resolving correctly based on all testing tools available.

I was able to add the IMAP email address to various email clients on Mac desktop (Apple Mail, MS Outlook) without any issue. The problem started when a client tried to add the IMAP to Outlook on Windows and the iPhone. Outlook is always reporting a “login failed”.

After few tests on my iPhone Outlook app I was able to isolate an error message on the server.

I replaced the correct email with name @ example. com and the real IP with “client_IP”

Any suggestions on why this is happening and what can be done?
Truly appreciate it.

  • I’m guessing it’s not a good day for me :slight_smile: I’ve tried multiple times to display the server error I’m getting but the forum will not allow me to do it. Finally. See below.

Warning: sqlpool (mysql) : Query failed, retrying: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near
‘CONCAT (’*: bytes=’, REPLACE (SUBSTRING_INDEX (pw_shell, ‘S’, 1), ‘NOQUOTA’, ‘0’)) A’ at line 1

Error: sql( name @ example. com,“client_IP”,): User query failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘CONCAT (’*: bytes=’, REPLACE(SUBSTRING_INDEX(pw_shell, ‘S’, 1), ‘NOQUOTA’, ‘0’)) A’ at line 1


The query messages are normal. It has been a red herring 100% of the time–I’ve never come across and issue where it is the cause. However, it is interesting that you are seeing those messages, as they should have been suppressed way back in January. I do see it on another customer server, as well, so I will make a note of that.

In the meantime, as we do not provide or directly support Outlook, I’m not 100% certain why you would be getting a login failed message specifically only on that client, other than potentially that the login/password information is incorrect, which I’m sure you’ve double checked. Can you reproduce consistently with Outlook, using other email addresses, or just this one user/password combination?

If you open a support ticket at, I can take a look for you and see if I can reproduce. I would need access to the server, as well, so you would have to provide the IP, port if anything other than 22, and make sure that remote assistance is enabled.

Friendly Neighborhood InterWorx Support Manager

1 Like

Good morning Jenna, thank you for your reply. I opened the ticket and activate the remote assistance. The issues seems to be related to the SMTP. I was able to add the accounts to Outlook on mobile by using the Incoming IMAP server and replacing the SMTP with the host and credentials from another domain on a different host managed by Cpanel.
Let me know if you need more info.

Thank you again.


Kudos to IW Jenna

What version outlook are you using

Do you have any symbols in the password - outlook does not like certain symbols

How did you set secure in outlook - auto SSL TLS - from memory it needs to be SSL on port 993

Smtp depends on outlook version - latest version I think needs 587 as outlook does not use starttls on 25

Lastly, you maybe aware, but in outlook you need to define root folder inbox to show mailbox

Many thanks


1 Like

Morning John, no symbols on the emails as far as I remember. There may be a - on one of them but even the testing email is just using something like 111111111 as password.

On Outlook for mobile you can’t select the the SSL TLS as you can do in the desktop version, so I’m assuming it’s on by default. Ports are 993 for incoming and 587 for SMTP outgoing.


Hi Alex

Many thanks

I have just checked on my iPhone, on SMTP is the following correct

Use SSL on
Authentication password
Smtp server set to correct smtp server

When did you switch dns over - is it stale dns cache and not resolving to new server, hence wrong password

If you want to pm me the domain and correct IP for mail outgoing server and I’ll check here. If you want to create a new mailbox and let me have details to connect on test mail box and I’ll test from my iPhone

Many thanks


If only I knew how to pm in here :joy: I can’t see any button

Since I just signed up to this forum I can’t send pm. Forum limitations. Happy to send info for your to try the domain.

You’re correct about the info on the iPhone if you use the Apple Mail program. If you download and install MS Outlook, when adding a new account the app will only allow you to define the host and the port. No option for SSL


I just saw the ticket you logged, and I am looking into this for you.


1 Like

Thank you Jenna, I just replied to you on the open ticket.


@fly @IWorx-Jenna I think the issue is a DNS record missing at liquidweb DNS for domain.

The missing record is MX A record for mail.<abc.url>

I think it is not correctly resolving due to missing record and may explain why it does not populate as a test from one of our domains does

@fly I will PM a test account from one of our servers and if could confirm if it works as expected.

I had a few other thoughts as well:

password too weak for outlook to use (maybe… but works OK in outlook desktop version)

<<domain.url>/webmail is not secure and does not have a LE SSL

Server only uses TLS 1.2 (perhaps try lowering to include TLS 1.1 as a test)

These are just thoughts though sorry

Many thanks



Sorry 587 does not work but 465 does

@fly have you set 465 is MSA

Many thanks


@d2d4j @IWorx-Jenna I received and correctly installed your IMAP on Outlook for the iPhone (465). Yes, you’re correct about the app not populating automatically on mine.

I also tried very strong password and the result is the same.

I can secure <<domain.url>/webmail, I had it before (yes I did reset everything) and it was having the same problem.

Where would you lower the TLS? Sorry can’t find an info there.

So, maybe it is a DNS issue. I will pm the DNS with LiquidWeb.

Big thank you to @d2d4j for solving the issue. Apparently Outlook is requiring SMTP port 465 to be open. In NodeWorx configuring the SMTP to accept 587 and 465 is not sufficient because the door for TCP is not automatically opened on the firewall, at least if you have ConfigServer Security & Firewall (csf) installed.

@d2d4j saved the day!

Hi Alex

Excellent news, glad it’s now resolved

5 hours difference isn’t soo bad. In UK it’s british summertime so our time changes by 1 hour depending on summer/winter time

Hope you enjoy IW. We’ve been using it for over 10 years

Many thanks and stay safe