Guys ClamAV is always stopping even if if i start it

guys ClamAV is always stopping even if if i start it


Run free -m. Is there swap memory listed?

Also, in regard to your other post, ClamAV being stopped would cause the email issues you are experiencing.


i got this
total used free shared buff/cache available
Mem: 1998 978 571 183 448 692
Swap: 0 0 0


That is the root of both the ClamAV issue and the email issue.

The server the Namecheap provided you does not meet the minimum requirements for InterWorx, found here: What are the system requirements of InterWorx Control Panel? — InterWorx documentation

Swap is required on all InterWorx servers, partially due to the requirements of ClamAV. ClamAV keeps its virus definitions in memory, which generally takes up about 1GB of RAM. If you do not have any swap on your server, there is no where for other processes to go when ClamAV tries to start.

ClamAV being stopped while SMTP scanning is Enabled (which is the default setting) will cause all inbound remote receiving to fail, because all outside mail will be rejected at the SMTP level, since there is nothing running to scan it.

You need to do two things:

A. Add swap to your server, in compliance with the minimum requirements in the documentation I provided. You may want to let Namecheap know that they provided you a server that did not match the requirements of the software they provided on it.

B. While you are waiting for swap to be added, in NodeWorx, under System Services > Mail Server > Virus Filtering. Where it says “SMTP Virus Scanning”, switch that dropdown to say Disabled. That will allow mail to come back in through the server.


ok but when i login to he vps server panel its shows swap 17 mbs


You need to talk to Namecheap about that. I don’t know anything about what shows in their interface. It doesn’t matter what their interface portal says, just what the server, itself, says.

Also, 17mb is not nearly enough. Per the documentation I provided you, at least 3GB swap is required.


ok so that means if someone send email its not going to be scanned as long as the situation is as it is



–Mail scanning cannot occur if ClamAV is not running.
–ClamAV cannot run if there is not enough memory for it to start.
–There will not be enough memory for it to start unless the min requirements for swap and memory are met
–Since mail scanning is enabled, mail cannot enter the server. It is being rejected since it cannot be scanned, since there is nothing running to scan it.
–Disabling SMTP scanning, as directed, will allow mail to enter the server while ClamAV is not running


i have disabled the mail scan and iam now receiving emails

also how to block incoming emails for a certain email like if i have one email for updates and i do not want people to sent or reply to that email how can i do it


I don’t believe that is possible.


ok but i have seen it possible with cpanel

It is not with InterWorx, as far as I am aware.

thank you have helped me a lot