How to increase PHP value at File Manager (PHP 8.2.9)

So I have a problem with Elementor Builder plugins, unable to edit it with elementor. Whenever I try to, it will always display Internal Server Error. At first I thought it was plugin crash each other, but its not work. So I try to increase the memory limit with wp.config.php but it still not work, then I thought maybe its the PHP version 7.4 so I upgrade it into PHP version 8.2

Now I’m not sure why, but it looks like after upgrading it to 8.2 the site isn’t responding to my php.ini file and wp.config.php. I set the memory_limit into 512M and upload_max_size is 256M,

but at the site info is different.

I tried to research about it, at this doc How To: Change InterWorx PHP Ini Settings — InterWorx documentation
But I dont know where to find /etc/opt/iworx/iworxphp72/php.d/90-iworx-overrides.ini its not at file manager? then where and how do I access it?

Please help… it has been month this problem still happening, It just mention I may need to increase my PHP value. but now there is problem to change the PHP value at File Manager.

Many thanks,


Hi Edberaga

Please do not change the Iworx PHP unless yoou really need to

I think you are getting confused over Iworx php and apache PHP

You need to change the settings in the apache php versions, and if you only change the settings on say php74 and not php81 as an example, then the change only applies to php72 as it is version specific

so all your installed versions (you can add more php versions very easily from nodeworx, system services, web server, overview - php versions and to make it even easier, you can see and add more extensions for PHP from nodeworx, system services PHP extensions)

So if you SSH into your server and run as root or sudo

vi /etc/opt/remi/php82/php.ini

change your required settings you need and save

restart either php82 or simply restart all php versions from nodeworx system services web server overview php - restart all php versions

if you view /etc/opt/remi you will see the php versions you have installed and to change a different php version say php 73 you would do as above but use

vi /etc/opt/remi/php73/php.ini

or php74

vi /etc/opt/remi/php74/php.ini


Please always remember to restart php or your changes will not work/show until php restarted

I hope that helps a little

Many thanks


where in the god can I check the /etc/opt/remi…?? this is what I have been looking for

how to run as root or sudo at interworx?

I really need to edit my PHP so I can use this elementor web builder at my domain


You would use sudo if you set it up on your server and if so, you just add sudo at start of the commands in ssh

If you have not set up sudo you just run the commands in ssh

I am sorry I cannot remember if you are a nodeworx or siteworx user

Many thanks and hope that helps a little


Look Im only asking if I could change the PHP at the file manager not using sudo, because I have no time to find how to do sudo or install it or configure it.

Moreover, why when I change at the .php.ini the one only change is at the version 7.4 after all I’m using the PHP 8.2…??

And why its not recommend to change interPHP?


Many thanks

From the sounds of it, your not using sudo so just run the command as root user

You are either only editing php.ini for 7.4 and not 8.2 or you are not restarting php so any changes are implemented

So your clear, this is a forum and I do not work for interworx

If your still having issues, I would open a support ticket with your license provider of interworx but please ensure you enable remote support in nodeworx

Many thanks


1 Like


Do you have access to NodeWorx, or are you just a Siteworx user?

If you have access to NodeWorx, can you tell me what the PHP mode is under System Services > Web Server? Does it say su_php or php-fpm?

Also, as a note, since there seems to be confusion, all of the things John recommended are tasks that would be completed at the command line–not in the InterWorx GUI. Those tasks cannot be completed via the GUI, or the file manager. You would need to SSH into the server at the command line via a terminal. A terminal is not included as part of InterWorx.

The file manager ONLY gives access to the files located under the SiteWorx user’s homedir. You would not ever be able to access or find /etc/opt/iworx/iworxphp72/php.d/90-iworx-overrides.ini because that file is not found under /home/your-siteworx-account’s-uniux-user.

Sudo is a word that you can put in front of a command when logged in via SSH at the command line if you are not logged in as the root user. It essentially says “I have permission to run this command” and it will then prompt for a password.

So, for instance, normally only the root user can restart Apache. But if I have an SSH user for that server called jswisher, and I have sudo permission, while logged in as that jswisher user, I can run

sudo service httpd restart

Which will then prompt me for my password, and then the command will run.

It’s not any kind of extra program that you would install on your computer, or need to configure or anything like that. It’s a command line tool that is only used if you are SSH’d into the server at the command line as a user other than root.


Hi again–

Actually, thinking about it, if you “upgraded” to PHP 8.2 from within SiteWorx, the only way to do that is by using the multiple PHP versions we provide, which are all PHP-FPM.

I think you are using the wrong kind of custom ini.

Custom php.ini files can ONLY be used for su_php. PHP-FPM requires a different kind of file, called a .user.ini file.

Try recreating your custom file like this, instead: How to: Set Individual/Per-Domain ini Configurations for Custom PHP Options — InterWorx documentation

If that does not work, you need to contact your hosting provider, as the change will need to be made at the system-level php.ini file (/etc/opt/remi/php82/php.ini), which can ONLY be accessed via the command line. You cannot edit that file from the SiteWorx-level file manager or the browser.

Also, this document that you found: How To: Change InterWorx PHP Ini Settings — InterWorx documentation is not for SiteWorx accounts, or the system PHP versions. InterWorx has an internal version of PHP that it runs for the software, itself. That is not related or connected to your website. And, again, editing that file can only be performed by the root user when SSH’d into the command line via a terminal. Not from the browser or any kind of file manager.


Yes, I have nodeworx access, and its mention php-fpm.

I see, no wonder it only works if I use .user.ini file… but that time I try to increase my max_input_time to 150 at .user.ini file it won’t work!

Anyway just update for this problem:
I have return it back my PHP version to 7.4.33, my problem was still exist… and Im just wondering, whats the difference between PHP memory limit, and wordpress memory limit?


For user.ini to work properly with any changes made, php needs to be restarted

You could also make php refuse to use any user.ini files or limit the changes it could make

Without confusing things further, will proceed on assumption your php.ini is a default .ini

Php memory limit is the max memory that php could use and word press php memory limit is the amount of php memory Wordpress can use

The 2 limits can be different but if Wordpress needs 512mb php memory but php.ini has memory set to say 128mb limit then 128mb is max memory limit for php version your using

I noted when you posted last that it was using php 7.4 and not 8.2

Please could I ask what max memory limit you are trying to set too

Many thanks


so I figured that wp.config only let the wordpress how much it needs to use, so my only choice is the .user.ini file, I was wondering how do I restart the PHP? Because I didnt see anything like restart php at nodeworx, or Im just not very detail…

So in order to use Elementor web builder, it was recommend this:

  • PHP max input variables (max_input_vars): 4000
  • PHP time limit (max_execution_time): 400
  • PHP memory limit (memory_limit): 256M or higher (512M recommended if you’re using WooCommerce or WPML)
  • Max input time (max_input_time): 400
  • Upload max file size (upload_max_filesize): 64M
  • PHP post max size (post_max_size): 64M
  • Runtime Configuration : allow_url_fopen:on, allow_url_include:on


Many thanks

Please could I ask where your screenshot came from as a check on your domain php version shows different values - see my picture showing your current php 7.4 settings in use by your domain (php7.4)

Your version of wordpress requires php8 or higher, so wordpress may not work correctly or as expected as well as some or all plugins

to restart php, the easiest method is to login to nodeworx, system services, web server, overview and click restart all php versions

To set those required values, I would edit the php.ini so it is available to all sites which would use that php version you changed and please remember to restart php for changes to take affect

Many thanks



Sorry I was wrong over wordpress 6.3 requiring php 8 or higher to work, it apparently does work with php 7.4 or higher

Many thanks



There is a button to restart PHP-FPM on the Webserver page in NodeWorx.

You can also do this at the command line (which is the recommended way) with:

systemctl restart php-fpm


service php-fpm restat


~iworx/bin/php-fpm.pex --restart-fpm


Hi Josh, Jenna

Many thanks as always for your help and information. I finally able to increase the value I need, Im just don’t have any idea it was unable to work at .user.ini before must be wrong name?

Anyway I manage to solve the problem… I really appreciate for your help as always. And I apologies for being rude to you Josh…! I was frustated and just deliver it to you…

Best Regards,



Glad you resolved your issue

The file name is correct but any changes only take affect when the php version used is restarted.

The file could be set to not be used even if it exists and could be set to allow certain changes which the server admin set but don’t think this is why it did not work

Many thanks


1 Like