How to stop /Chroot/ redirects from appearing inbetween websites links uploaded on siteworx

We have problems with " /Chroot/ " appearing inbetween websites links hosted on Siteworx/interworx.
We want to know how to stop this from appearing.

For example: when this link is visited, https://ourdomain.url/dir/admin it redirects to https://ourdomain.url/chroot/dir/admin/login.php
and shows up /chroot/ inbetween the links with this response
"Not Found

The requested URL was not found on this server."

But when visited in this manner, adding the login.php to the link ie: domain
(dot) com /dir/admin/login.php everything is fine.

Kindly how do we rectify this for all our customers ?

Hi Simdia

Welcome to IW forums

I have edited your links so they do not go to a proper website!

I think this is a document root path issue which you may have wrong

You can use /home/unixname/etc… instead of /chroot/home/unixname/etc…

I think also your apache is not set to use php as default, so you can edit your apache config (nodeworx, system services, web server, edit apache config and tell apache to use php as default (php html etc… as you need) and save/restart apache

As I do not know the exact setup you have, if this still fails, you would be best advised to open a support ticket with your IW licence provider and let IW have a look. Please be aware though, IW only support IW-CP and if your issue is with websites hosted, IW may charge but there usually very good and just let you know

Many thanks


1 Like

Thank you John for the assistance.
One more thing as i followed your instruction.

At which line in the below file do i make this change / include php as default ?
“File = /etc/httpd/conf/httpd.conf”


Hi Simdia

I would not advise manually changing/editing httpd.conf but use teh IW-CP to make changes.

This is not because you may not know what you are doing, it is just easier and quicker and please remember, IW uses a conf.d to add additional conf into apache, which you may double start of additional conf and cause apache to stop. Only manually edit using SSH if you fully understand the process of apache

Please see picture attached, as taken from IW-CP for editing httpd.conf and you change directoryindex

Many thanks

Johndirectoryindex apache

1 Like

Thank you very much John,
I was able to add the ‘index.php’ / change the directoryindex in the apache httpd.conf config file as you showed.

But ran into other issues i would like to address:

1). I created a test directory called cyber/admin2 thus; , then created 2 files inside this directory namely; index.html and index.php

When was accessed, everything worked well, index.php file content displayed. ( note; this was after you gave the instruction to the change in Apache config file ).


2). The main site content which we have lots of .php files like, index.php, login.php, logout.php, register.php, confirm.php etc… ( when accessed, takes me back to - displaying an error page ).
“Also note that this particular link works very fine on Control panel ( Cpanel ) which takes me to without any problems.”

Furthermore, i had to remove the chroot inbetween, and added login.php at the end, and admin was logged in.

The main issue is: inside admin area as shown in the 1st photo image, when “User Details” menu is been clicked, it takes me back to the 2nd photo image, with error, which seems to me that when only directories are accessed, there is this issue…

Kindly assist if there are any other things to add inside the Apache config file to enable all directories function properly, and never to have chroot inbetween links of any kind.

Many thanks

Hi simdia

Many thanks

Looking at your last post, I do not think now it is a document root path issue.

With IW, if you created the directory Christ in the initial distribution prior to installing IW, IW would use chroot and put home into chroot. If there were no chroot directory before IW install, then it just uses home

So I am thinking as your link shows /chroot/cyber/ then it is not doc root path

You would need to look at your php code for those links not working and check if hardcoded with chroot

I think in your website, you may have an area to set admin path so maybe check as well

Lastly, on old host, did you have a chroot directory in the domain hosting area.

Chroot normally indicates jailed

This though is not an IW issue

If you could update your post after you have checked for hardcode links containing chroot

Many thanks and I hope that helps a little


1 Like

Just a note that this has been escalated to the help desk. :slight_smile:

Friendly Neighborhood InterWorx Support Manager