httpd.conf and webalizer.conf

A few weeks ago, I noticed that the custom settings I made in webalizer was undone!

I noticed this because one day I checked my stats, and it did not list the number of entries I had specified for referers.

I also have strange problems with .htaccess, first of all to protect a folder and even simple Rewrites which are totally ignored!

My question now is, did you guys (InterWorx) as part of an update or maintenace upload new httpd.conf and webalizer.conf files?

Or did you guys even change the site template, because the first few sites I created, .htaccess works fine? Very strange…

Looking at the httpd.conf file, in /etc/httpd/conf I noticed this:

AllowOverride controls what directives may be placed in .htaccess files.

It can be “All”, “None”, or any combination of the keywords:

Options FileInfo AuthConfig Limit

AllowOverride None

Is that right? None does not seem to be right!

Looking further in this file:


I see the following lines:

Set the default to not look for .htaccess since

this must be done for every URL request.

<Directory />
AllowOverride AuthConfig FileInfo
Order deny,allow
Allow from all

Options -Indexes -Includes

And this file was edited, or last changed on March 30th. 2004, NOT by me!?!

I look forward to somebody can explain this to me…

The /home/interworx/etc/httpd/httpd.conf file is the configuration file for the InterWorx server, which listens on ports 2080 and ports 2443. This file doesn’t have any affect on your websites created via InterWorx.

That’s not to say you aren’t seeing a problem, but that isn’t the source of it.

We haven’t seen any problems with .htaccess password protecting on InterWorx servers. If you want to post the contents of your .htaccess file we’ll be happy to take a look.


Doing some more checking, it seems that I can get Rewrites to work in .htaccess on newly created sites.

However I still have a problem with creating a protected folder, and no I am NOT using SiteWorx File Manager for this.

I put in an .htaccess in a folder I want to be protected, example, similar to this:

AuthName “Members Only”
AuthType basic
AuthUserFile /home/mywebsit/
require valid-user


As can be seen above, the .htpasswd file is located in

When I then go to using Internet Explorer, I get an “The page cannot be found” error, even though I have an index.htm file

What gives?

Anything useful in the apache error logs for that domain?


Hmm, never looked for those.

Where do I look that?

Sidenote: Website errorlogs. I’m used to CPanel, where I could access error logs from within there, hope you guys will add that feature to SiteWorx soon :slight_smile:

The error logs are already available in SiteWorx, and I believe you posted a while ago complaining that the lines were truncated (which they aren’t any more) :slight_smile:

Check under the “Logs” menu in SiteWorx.


This may or may not have anything to do with my problem.

Why is that when I use Tectia’s SSH Client program or WS_FTP Pro, the SSH function port 22, to transfer a file or folder, why it then that I can’t access, view or transfer to, that folder using DreamWeaver?

And I did use SSH one time to edit the htttp.conf file.

Is SSH putting some file permission on the folders and files, DreamWeaver can’t handle? Website still works fine though, just can’t view my files!

Actually I solved this problem with the files on my website, by simply deleting them in SSH, and then uploading them again using WS_FTP Pro regular FTP port 21.

Or is this something to do with “Tunneling” which I know NOTHING about?

Me “complained”? Never :slight_smile:

Don’t worry, the complaining was completely justified.

If you’re ssh’ing as a different user than the owner of the files, you won’t be able to see them in FTP. You’d have to “chown” the files after you uploaded them.

ex: chown mywebsit.mywebsit filename


After entering this address in IE:

I see this error:

0: [Sun Apr 25 00:37:43 2004] [error] [client] File does not exist: /home/mywebsit/

And I just double-check, the file is there!

By the way I have edited httpd.conf like this:
ErrorDocument 400 /400.htm
ErrorDocument 401 /401.htm
ErrorDocument 403 /403.htm
ErrorDocument 404 /404.htm
ErrorDocument 500 /500.htm

That explains the error log looking for the 401.htm file, which I have actually not put up on that site yet. But why can’t it find my file?

Oh my God!!!

You won’t believe this, uploading a 401.htm file made it all work!?!

Now please explain why a protected folder needs the error file?

That is the weirdest thing ever…

Hard to say, that doesn’t make much sense. 401 is “Authorization Required” which is what you normally get when you type the wrong password a few times. Any chance you restarted your browser, and that’s when it worked?

I’m not sure how the absence of the 401.html file would make a difference.


No I did not restart my browser, just uploaded the 401.htm

“chown mywebsit.mywebsit filename”

Where do I chown?

You would do it via the ssh command shell.

Ahh, thanks