IMAP namespace?

Our old non-InterWorx box apparently supported the IMAP NAMESPACE extension, but our newer InterWorx box does not (or it does not work). See this URL for mostly related info: The main symptom of the namespace value being defined incorrectly (or not at all) is the email client fails to copy anything to the Inbox subfolders, including “Sent” and “Drafts”.

We usually tell clients that want to use IMAP to set their namespace values, ignoring the fact the server should be supplying those values automatically. This worked fine, until yesterday when a client brought Apple Mail to the table, an email client that does not appear to provide that option for the end user. Probably a by-product of Apple trying to simpify the user experience.

Apple Mail does provide an IMAP prefix option, but while that is similiar, it is not the correct configuration option to change. I have attached my Thunderbird Advanced Account settings, which work perfectly, except for the fact I had to manually enter them.

Does anyone know how to fix this? I have had very little luck with it, and now it is directly affecting a new customer… :frowning:

Note: I think this may be an InterWorx bug, because I have not altered my out-of-box configuration for Courier IMAP.


I don’t have an apple handy to test with here but this url looks like it might be relevant.

Set ‘IMAP Path Prefix’ (under Advanced) in Mail->Preferences->(account)
to ‘INBOX’ (no period after), BEFORE you finish setting up the
account. If you’ve already set up the account, remove and re-add it
with INBOX set before you let Mail check the account.

As far as I can tell, “IMAP Path Prefix” is equivalent to “IMAP server directory” (in Thunderbird). That setting always is blank for a default install, as far as I have seen.

I think I have tried that newsgroup recommendation before, but I tried it again just to be sure. I was careful to create a new account and set the INBOX value before letting Apple Mail check the account. All that really happened was Apple Mail successfully accessed the subfolders, but Sent and Drafts on the IMAP server were never used. All sent mail was copied to the local “Sent” instead (similiar for drafts), presumably because Apple Mail saw no alternative (no error messages this time).

My theory is if the server were correctly providing the IMAP namespace information through the IMAP NAMESPACE extension, Apple Mail would actually use the server-provided namespace value and everything would work. Courier-IMAP implements the extension, but I have never successfully convienced my InterWorx box to offer this information, like I my previous Linux box did by default (Courier-IMAP there, too).

Does anyone here use IMAP? I know it is not as popular, but I would think more of you would be experiencing this problem – not with Apple Mail, but IMAP namespace configuration in general. :confused:

I have learned that IMAP clients will only try what IMAP_CAPABILITY declares in the configuration. When I telnet to localhost:143, I get:

telnet localhost 143

Connected to localhost.localdomain (
Escape character is ‘^]’.

  • OK [CAPABILITY IMAP4rev1] Courier-IMAP ready. Copyright 1998-2003 Double Precision, Inc. See COPYING for distribution information.
    The server is currently declaring nothing more than IMAP4rev1 capability. I copied /etc/courier/imapd.dist to /etc/courier/imapd and verified the IMAP_CAPABILITY variable is set to the default value most “How-to” documents have shown:

After /etc/init.d/imap4 restart, I still get the same response from the IMAP server. :confused: Is InterWorx-CP managing a hidden configuration file somewhere else? I have courier-imap-2.1.2-100.rhe4x.iworx installed.


Does anyone have any new information regarding this post?
I just had problems with a client using Thunderbird with IMAP access and could not create Sent, Trash and Drafts folder as subfolder of Inbox. A manual creation of a subfolder from Thunderbird worked though, but if we created i.e “Sent”, Thunderbird still could not use it.

If we specified INBOX. as Imap-serverdirectory, Thunderbird could create the special folders, but not as subfolders of Inbox.
I have 2 other courier imap servers that works with subfolder, but cannot find the difference from the one on the Iworx-box. imapd.cnf are the same on all servers.

What Jimp says makes sense, it seems that Courier on the Iworx-box does not present capabilities correctly:

Courier with working subfolders

pandora root # telnet localhost 143
Connected to localhost.
Escape character is ‘^]’.



pandora root # telnet Iworx-box 143
Connected to imap.server.tld.
Escape character is ‘^]’.

  • OK [CAPABILITY IMAP4rev1] Courier-IMAP ready. Copyright 1998-2003 Double Precision, Inc. See COPYING for distribution information.

Thanks for any information on this.


Here is the solution.

Hi tsl,

When I orginally posted this, I ended up opening a support ticket because I thought the problem might be focused on my server. However, it was determined to be a configuration problem that I just was looking for in the wrong places.

I just searched my old emails, and found the solution, which I really should I posted here long ago (sorry about that):

I manually merged these changes into my own file, with the most significant problem being the missing "[SIZE=2]cat /etc/courier/imapd.dist | /usr/bin/envconv

exec envdir ./env [/SIZE]", which loads the configuration file when starting the Courier daemon.

After fixing the startup problem, the IMAP CAPABILITIES were advertised correctly and Thunderbird accounts became “self-configuring” again.[SIZE=2]

Jimp (and Paul),

Excellent advice…it worked perfectly :slight_smile:

Many thanks

Very helpful thread. Thank you jimp, Paul, tsl, et al.