install problem rpm

when i execute
.\ -f
I get the error:
.\ requires ‘rpm’ to be in stalled

When I execute apt-get install rpm with success en I redo
.\ -f
I get the same error

What is going wrong?

(When I don’t use the option -f I get the error:
distribution not supported)

My system is a basic debian server 7.0


I’m not an expert sorry, but have you reviewed the following

I am thinking you have not downloaded the package, and you have not installed yum (although I don’t know if it will install using any other method) as the installation docs state it is installed using yum (sudo yum install)

I think I am correct in thinking that Interworx does not support debian ( but I could be wrong, and personally I like Centos, although Evanion like secured Linux, so you may want to either wait and see if a more knowledgeable user posts or perhaps change your OS if possible.

I hope this is of some help

Many thanks


You need a RedHat fork like CentOS for Interworx. It won’t work on debian based systems.

We run CloudLinux, which is a fork of CentOS.
CloudLinux have some additional features that are developed specifically for shared hosting; resource throttling of CPU/RAM/HDD IO etc, LVE and CageFS (a type of jailkit with all the bugs fixed).
CloudLinux cost about $14/month. Money well spent if you ask me.

We also run Atomic Secured Linux, which is a Firewall and web application firewall. It helps to protect your system form most known exploits of common systems like Joomla, Wordpress and Drupal.
I would not recommend you to run ASL, unless you’re an experienced system administrator. (cost $299/server/year)

Hi, forum people!

d2d4j’s correct. We don’t support Debian servers at this time. The authoritative list of supported configurations can be found at

Evanion mentions Atomic Secure Linux, and like he says, while this is also an OS which can be used to build a supported configuration, please, please, PLEASE know the system like the back of your hand before you try it, especially with respect to firewalls!

louis14, if you do get a Debian configuration working, please let us know! That’d be very interesting! My first guess is ‘# apt-get install rpm’ followed by running the iworx install script (because it can now find rpm on the system), but I could imagine that you’d very quickly need to specify some rpm repositories (maybe steal Fedora’s base list?), but I’m not quite sure how many other ancillary packages iworx will need to pull down. I haven’t tried this experiment myself yet, so I know about as much as you do regarding the problems you’ll run into. :stuck_out_tongue:

Happy software engineering!

EDIT: I had an opportunity on 11/11 to conduct my own experiment. Used ‘./ -f’. Said it couldn’t open iworx-install.log. So, ‘touch iworx-install.log’. Try install script again; got the ‘needs more RPM’ error. ‘apt-get install rpm’. Same error. ‘apt-get install yum’. Same ‘needs more RPM’ error. Looked inside the script. Saw what I think was evidence that it was looking for ‘/bin/rpm’, but ‘which rpm’ gave me ‘/usr/bin/rpm’. So, ‘ln -s /usr/bin/rpm /bin/rpm’. New error: “ERROR: ./ requires UIDs 102 -> 107 to be unused”. That’s interesting. And it’s progress. I don’t have the spare brain energy to screw with Debian UIDs right now. So, I’m done for now. I have too much other stuff to do at the moment.