Installing + GDIs 102 -> 103

Hey everyone,

I have a fresh install of Fedora Core 4 and when I try to run the install script “” i get the error

“Importing RPM GPG Keys
ERROR: requires GIDs 102 -> 103 to be unused”

Like i said this is a fresh install so im a bit confused…


If your fresh install put on an smtp server or pop3 maybe those are using those ids. Try removing those if they are there. Just check the /etc/group and see.

Although you may want to put in a ticket b/c im not 100% sure thats the problem.

What is using uid 102/103 bill?


You can find out by looking in /etc/passwd

The reason it’s a problem is that qMail needs those uid’s.

Is this on a dedicated server or a vps? I had this issue on a vps once when I did a reinstall of the vps and left the user table intacked so the qmail rpm was removed but the qmail user wasn’t. Could this be your problem?


hey guys, sorry I didnt get the notification that anyone responded.

I took justec’s suggestion and looked in /etc/group…there was a program, I dont remember which, but was using GID 102. I just uninstalled it and deleted the line from /etc/group…all i well now…

thanks for the help, sorry I didn’t get back to you guys sooner.

For the record, I notice that anytime I do a “install everything” install of any linux distro, I have a bunch of problems. This may not be the best option for many people. Any suggestions on what the “ideal” install is?


Hi mpcomputer,

We recommend doing a “Server only” install when installing the OS.

Hope that helps,

That’s a good point. As Socheat said, a “server only” install is generally best. Both from a “less headaches during install” standpoint as well as a security standpoint – the more running on the box the more youneed to keep up to date and the more possible secutity holes. The InterWorx-CP installer script will install any PM’s that it needs that are not already present on the system, so there are no worries there.