Internal server error while opening softaculous

Hi everyone!

I have a dedicated server for over a year now and I host around 20 websites. I used softaculous to install more than 100s of accounts during this time. Recently I was busy and didn’t log in to my server for a time(around 10-15 days).

Two days ago I logged in to install a new softaculous script WordPress and a mailing system. However, after logging in to my Siteworx account, when I clicked on Softacolous I got an Internal Server Error. I tried to open softacolous with other/new Siteworx accounts and all of them gave Internal Server Error.

My system is Centos 7, PHP 7.4, running apache.

I tried:
-Reinstalling Softacolous(multiple times) and no errors and no result(still same).
-I tried switching to suPHP and configuring settings within Nodeworx’s Softaclause(didn’t work so switched back to PHP-FPM)
-Some people suggested to update Soap(have no idea what it is) and it was already latest version.
-Checked all SSL certificates.
-Someone told me to run a line of code for Softaculous binary utility repair and it didn’t fix the issue

BTW there are no error logs. No error logs in Softaculous and no error logs within the nodeworx or siteworx(just 500 in access log (myserverip:2443/siteworx/softaculous))

Please help. Thank you!


Have you restarted your server

I would open a support ticket with IW as you stated no error log

Many thanks



Yeah, I did restart the server every time I made any change.

I had a ticket open, but it was taking time to resolve it. However, their support finally resolved the issue.

As stated by their support, it was a rare bug caused by Softaculous. They temporarily fixed it for me. They told me that they will update the patch next version.

Thank you!